Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

NI 9214 having issue with a common-mode range error

Solved!
Go to solution

Hey,

  I am taking readings using k-type thermocouples using the NI 9214 module in a cRio.  System works great at room temperature, but once I take the area around the thermocouples up to 300 degrees C, I keep getting the error: "A common-mode range error was detected." 

 

  I am using the NI 9214 in High resolution mode, with OTD disabled.  I have gone through the documentation on the error, but it is light on suggested solutions.  I am wondering if anyone else has seen this, and if so how you solved it.

Thanks!

0 Kudos
Message 1 of 3
(3,054 Views)

Hi iambaconman,

 

Most of the cases of this I have heard about happen when the isolation paste between the thermocouple and whatever it attaches to breaks down, causing a short, typically to ground. Basically, somehow you have exceeded the allowable common-mode voltage range of the 9214. This is most likely going to be a grounding/noise issue with how your thermocouples are hooked up. Can you tell us more about the setup? Are these shielded thermocouples? Are they measuring anything that could short to ground or are they in an environment that could have a lot of EMF noise?

 

Cheers,

GiantDeathRobot

William R.
0 Kudos
Message 2 of 3
(3,000 Views)
Solution
Accepted by topic author samtbacon

Hey GiantDeathRobot,

  Thanks for the reply! It was very helpfull.

  Let me start with the additional info on my setup.  I am using a k-type thermocouple into a vacuum chamber to measure some stuff inside.  I have the NI-9214 in a cRIO just taking data of the current temperatures.  The thermocouples are unshieleded in the chamber, but are only exposed at the end inside the chamber.

 

  Your grounding comment got me thinking that there could be an EFM noise issue.  So I solved my problem in a weird daisy chain.  I had the common for the NI 9214 wired to the common lug nut on the connecter.  I added a ground cable from the power strip I am using to power all the components in the chamber(including the cRIO) to the cRIO chasis.  This cleared up my noise issue completly.  I figured I would follow up, in case anyone else out there is struggling with this as well.

Message 3 of 3
(2,988 Views)