Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Missing toolkit or daqmx.RC

Go to solution

I have been away from Labview for a few years, (2013) but, recently, I have a simple need that I could be easily addressed by some VIs I wrote and tested and proved, and they worked GREAT!!!  However, when I open the PC that had these working VIs on them, and open in the older version of Labview, e.g.Labview 2013, every VI I open is broken and missing subVI or something...and then it is searching the folders on my PC for something...exactly what, I do not know...but, it just keeps searching and never gets the VI back into it's previous working order.  I have not made any changes on this older PC, so, I am not sure at all how to troubleshoot this.


It gives long list of "missing" items, but, I don't recall how to find them, and install them...  it's very confusing to me that VI's can sit on old PC, that has not been run in several years, and lose parts of themselves without any changes being made on the PC...this PC is running windows 7.  


I am merely trying to read the voltage from a NI-9211, which has a range of -80mV to +80mV, and is ideal for my voltage reading application.  How do I bring my VI's back to life??  I wrote dozens of VIs that started with reading the voltage from the NI-9211, and then, subsequently measuring other stuff, and creating control commands to my automation etc.  The voltage reading was simple, but,  now it is hard. I have read some things on the message boards about re-installing drivers....what drivers, and how do I re-install them?  Is it possible that the drivers or the VIs have become corrupted by sitting around for years without the PC being powered ON?


  Here is the error message I get, in the attachment.  Here is another example of the block diagram with pieces greyed out, and apparently they were stolen from my hard drive.  Here is also one example of the actual VI, with the missing parts.  I just want a very simple VI to measure voltage from my 9211, and let me capture the voltate data...just 5 samples/second...relatively slow...simple...  Grateful for advice...I have lost a TON of time troubleshooting this...thought it would be simple to re-use some old code, and it's turned into a nightmare.  Self test on MAX works find.


Also, NIMAX self-test shows everything connected and NI-9211 in cDAQ 9174 is working fine.

Thank you very much!





0 Kudos
Message 1 of 8

A quick google search using the keyword "daqmx.rc" gives the following link.

Missing Resource File “daqmx.rc” When Opening a VI in LabVIEW

0 Kudos
Message 2 of 8

Thank you, ZYOng.  I was searching the NI boards instead of Google...  admittedly, I am a bit rusty on Labview having not used it regularly for a few years now.  I will try the recommendation you offered.  Thank you,


0 Kudos
Message 3 of 8

OK, so, it is a bit more involved than just downloading from a link. I downloaded version 16.1, which is listed as the compatible DAQ drivers for Labview 2013...about 1.8G file size, and then, I went through a long installation process, of hitting NEXT and OK etc...took about 2 hours total to do.  Then, I opened LV2013, and opened the same VI as before, and was greeted by the exact same error.  Then, Labview spent about an hour searching my PC for something...not sure I understand what it is looking for, or where those DAQ drivers that I downloaded and installed went.  It kept updating the dialog box with "LOaded 16"...."Loaded 17"...."LOaded 59"..."Loaded 60" etc.  So, am I better off using a higher level of LV, e.g. LV 2020?  I'm totally lost on the DAQ installation...  Where did these drivers go?  Why is the VI still saying it is missing the daqmx.RC

0 Kudos
Message 4 of 8

OK, so I tried to repeat the installation of the 2013 DAQ drivers, package, and I watched the install more closely, and the message in the attached picture appeared  "can not install etc."  ... I have Labview 2020 also installed on this PC; does the existence of LV2020 mean that Labview 2013 CANNOT function?  Since I am working in Windows 7, the drivers for LV2020 cannot be installed because they required Windows 10....should I just uninstall the LV 2020?  So, I cannot get either 2013 or 2020 to work.


so, when I try to open this VI, it searches and searches, and finally Or, can you tell me why it is saying that the subVIs are missing?  I can't figure out what the fix for it would be?  Are all these subVIs missing because some driver is missing somewhere else?  It won't allow me to install the DAQ drivers, but, it still gives the error saying that they are missing...kind of a hard spot to be in.

Thank you

0 Kudos
Message 5 of 8

Most NI drivers are backward compatible for four version of LabVIEW. If you are using LabVIEW 2013, the latest NI-DAQmx version you can use is 16.1, as stated in the NI-DAQmx 16.1 Readme



And yes, you cannot get both LabVIEW 2013 and 2020 to work at the same time. There is no one DAQmx version that will support both LV 2013 and 2020.


0 Kudos
Message 6 of 8

Thank you for the explanation about the backwards compatibility.  So, what do you suggest I do, uninstall the Labview 2020, or upgrade the PC to Windows 10 to allow the DAQ drivers for LV2020 to be installed?  I urgently need one of these simple voltage readers to work to complete my project.

Thank you,


0 Kudos
Message 7 of 8
Accepted by topic author dav2010

Using LabVIEW 2013 and NI-DAQm 16.1 in Win7, or LabVIEW 2020 and NI-DAQmx 20.0 or later in Win10 would work.

If your computer is connected to the internet, I recommend upgrading to Win10 for security purposes as Win7 is End-of-Life.

0 Kudos
Message 8 of 8