Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

M series USB-6212 Output and Calibration Problems



I have a NI USB-6212 DAQ and am having trouble with the output signal/voltage.  I have tried to do a self calibration but it always fails.  I ran the DAQ Diagnostic Utility and got results that agree with what I was thinking but am not sure where to go from here.  Any help would be great.  I will post my Utility results below.  When I* try to have it do the self-calibration it fails and won't continue so the results shown below are with that step skipped so that I could show the results. 


10/4/2011 12:34:15 PM

Results saved to:  no location selected (results not saved)

Selected Device: Dev1

Device Type: USB-6212 (Mass Termination)

Serial Number: 1428EF1

Device Support: (PASS)

NI-DAQmx Version: 8.9 (PASS)

Device Reset: (PASS)

The device was last self-calibrated on: 4/9/2009 7:05:09 AM

Device calibration skipped.


-------------------- Testing Counters... --------------------

Testing CTR Buffered Pulse Generation...   (PASS)

Testing CTR Single Pulse Generation...   (PASS)


-------------------- Testing Analog Input... --------------------

Testing AI Ground Reference...   (PASS)

Testing AI Voltage Reference...   (PASS)

Testing AI Finite Sample Clock...   (PASS)

Testing AI Finite Sample Clock Frequency...   (PASS)


-------------------- Testing Analog Output... --------------------

Testing AO Finite Sample Clock...   (PASS)

Testing AO Finite Sample Clock Frequency...   (PASS)

Testing AO Single Point...   (FAIL)
************ Test FAILED for the following reason ************
This test failed to output 0.000000 Volts on Dev1/ao0.  The actual value written was 1.706730.

Testing AO Accuracy...   (FAIL)
************ Test FAILED for the following reason ************
This test failed to generate a voltage waveform with an error of less than 0.076208 Volts on Dev1/ao0.  The actual average error was 4.083570 Volts.


-------------------- Testing Digital IO... --------------------

Testing DIO Lines...   (PASS)

Testing DIO Ports...   (PASS)



Not sure where to go from here.  Any help?


0 Kudos
Message 1 of 3

I'm running into a similar issue. Ao0 is pinned at 1.5 V (unless the single point output is set to a larger value) and the self-calibration fails. Did you end up finding a solution?

0 Kudos
Message 2 of 3



Could you create a new post for this issue? Since this is an older post it is better to make newer posts even though it is a similar issue. You'll get better help this way and more visibility.

Marina B.
Technical Support Engineer
National Instruments
0 Kudos
Message 3 of 3