Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Getting error code -229771

Go to solution

I've just downloaded NIDAQ902f0.exe and installed.  MAX reports version 4.6.1f0.


Using MAX I have a device NI PCI-6731 with 4 analog output ports (Dev1/ao0 - Dev1/ao3).


When I run my program and try to create a write task:


// Ask the NIDAQmx API to create a new task object.
ecode = DAQmxCreateTask("Write TTM actuator commands", &ni_write_task_);


I get ecode -229771:


Processor.cpp:1094: ecode = -229771, Internal Software Error occurred in MIG software. Please contact National Instruments Support.
Task Name: Write TTM actuator commands

Status Code: -229771


Any thoughts?

0 Kudos
Message 1 of 5
Did you do a search and see the same error reported recently?
0 Kudos
Message 2 of 5


Hmmmm.  Seems ok on spec-


contains this GEM   "

NI DAQCard-6715 Analog Output

Hardware-timed single-point mode and hardware-timed nonbuffered mode are nonfunctional. Your application is using hardware-timed nonbuffered mode if you have set up a sample clock and a buffer size of 0, or set up a sample clock, but do not begin writing until after you start the task. All other waveform and static analog output modes work as expected."


I can't see why this would be specific to the 6715 and not general to the 67xx family.


The explaination is a bit vague- I'ld like some additional information


NI Appl engineers are available - I just rqd help from Contact NI:


Message Edited by Jeff Bohrer on 01-23-2010 11:59 AM

"Should be" isn't "Is" -Jay
0 Kudos
Message 3 of 5
Accepted by topic author weegreenblobbie

Are you using a 32-bit or 64-bit version of Windows?  And is it XP, Vista, or Win7?  What application development environment are you using? (Visual Studio 2005, 2008, etc.)


Also, could you try opening the Command Prompt in Administrator Mode and enter "net start mxssvr"?



Seth B.
Principal Test Engineer | National Instruments
Certified LabVIEW Architect
Certified TestStand Architect
0 Kudos
Message 4 of 5

I was stommping on some memory else where in the program, by the time I got to the NI calls, I corrupted some memory.


After fixing my memory problem, all is working as expected!

0 Kudos
Message 5 of 5