Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -15103 or resource lock in Windows 7 64 bit

I am attempting to switch a system running on Windows XP to a Windows 64 bit computer.

 

I am using DAQmx 9.8, MAX 5.5, cDAQ 9178 with 9215 modules through USB, Dell Optiplex 7010 64 bit, Windows 7 SP1.

 

I've run into an issue where the resources for a global channel are not released after using them.

 

This occurs in two different .NET programs and also in MAX.

 

The first time you begin to read the data (in the programs) or run the channel (in MAX), it will display data as normal.  However, after stopping the read (in the program) or stopping the channel and exiting MAX (in MAX), and then starting to read or run again, the programs or MAX will either a) lock or b) display error -50103. 

 

Cycling power to the cDAQ will reset it and you can see the behavior described above again.

 

Has anyone else encountered this issue?

 

Thanks for any insight you can give me.

0 Kudos
Message 1 of 4
(3,438 Views)

Hey dc128,

 

That error -50103 refers to the issue where the resource is reserved by some other process. If you application is not closing out correctly, the references will not close so you will not be able to run the a panel in MAX. Also, you cannot concurrently run your Application and MAX at the same time 

 

Does the application work on a Windows XP computer? Have you tried recompiling the code on a windows 7 computer and trying to deploy said code to that computer? 

 

There is a pretty good KnowledgeBase the goes over a few reasons why this might be happening. In order to clear the task in DAQmx just call the Task.Dispose() method when close out the application. 

 

This might be a question better suited for the Multifunction DAQ section of the website because it deals more with the DAQ system.

 

http://forums.ni.com/t5/Multifunction-DAQ/bd-p/250

 

Best Regards, 

 

KP

Kurt P
Automated Test Software R&D
0 Kudos
Message 2 of 4
(3,426 Views)

Thank you for the response.  I've worked my way through the knowledge base eliminating potential causes.

 

Here are a set of specific circumstances that lead up to appearance of the issue.

 

1.  The computer is shut down/powered down.

2.  The cDAQ chassis is powered down.

3.  The computer is booted up.

4.  The cDAQ chassis is powered up.

5.  MAX is opened and a global virtual channel is selected and run.  It displays readings properly.

6.  The channel is stopped and MAX is closed.

7.  MAX is reopened and the same channel is selected and run.

8.  Either an error -50103 appears or the "stop" button flashes, changes to "abort", and becomes non-functional.  No readings are displayed.

 

Neither of the .NET programs have executed at this point.  This computer is a clean image so there should be no program able to access the resource other than MAX and the two .NET programs.

 

Is it possible for me to move this post to the proper forum or do I need to repost?

0 Kudos
Message 3 of 4
(3,423 Views)

We should be good now, (the mods moved this to the Multifunction DAQ board). 

 

As for the global virtual channel, how was that configured?

Did you import that setting?

What happens when you try to run a test panel with the device instead of a virtual channel?

Does that still come up with the same error?

What version of DAQmx is installed to the computer?

What is the version of MAX? (the best way to get this information is to go to the software tab in MAX and take a screen shot and upload it. 

 

I think we don't have to worry about the .NET application; let's focus on MAX for now.

Kurt P
Automated Test Software R&D
0 Kudos
Message 4 of 4
(3,398 Views)