Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

DAQmx Write invoke node leads to Runtime Error (R6025 - pure virtual function call)

Go to solution
I have an application in which a subVI calls DAQmx Write invoke node (writing offset and reading NumChans).

When I start up LabVIEW and run the main VI a first time, everything works fine. When I run it a second time, LabVIEW crashes with a runtime error at the DAQmx Write invoke node:
R6025 - pure virtual function call

The LabVIEW failure log file contains the following lines:
c:\builds\penguin\labview\branches\Saturn\dev\source\compiler\allocsup.cpp(662) : DWarn: dataspace moved at run-time!
$Id: //labview/branches/Saturn/dev/source/compiler/allocsup.cpp#18 $

Does anyone have an idea how this crash could be avoided?
0 Kudos
Message 1 of 3
Accepted by topic author dlanger
Problem solved: we just removed the NumChan (read) line from the invoke node and readded it again. Now it works fine.
0 Kudos
Message 2 of 3

Run sfc /scanow
To do so, you will have to first open an elevated command prompt window. To run the System File Checker in Windows 10/8/7, type cmd in start search box. In the result, which appears, right click on cmd and select Run As Administrator.
type in "sfc /scanow" w/o quote.
Check for the other ways to fix this issue.

0 Kudos
Message 3 of 3