Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQCard AI-16XE-50 Problem

Hello,
 
I am using a DAQCard AI-16xe-50 PCMCIA card connected to an SCC 2345 carrier. I have a TC01, SG24 and DIO1 modules installed in the carrier. The values comming from the TC01 and SG24 modules are very strange very high or low. The input from DIO1 module is working.  My hardware was working correctly a few days ago.
Is there a problem with the DAQ card or could it be software?
 
Thanks,
Paul
0 Kudos
Message 1 of 2
(2,115 Views)
Hello Paul,

It would definitely help to have some more information about what behavior you are seeing.  Are the analog input values rising or falling to the maximum or minimum specified in the input range of your DAQ task?  This behavior is called 'railing', and this will happen when taking a measurement from a channel that has no signal connected to it.

The best way to determine if the problem is something hardware or software related is to see if you can replicate the behavior in the test panels in Measurement & Automation Explorer.  First you will want to make sure that your device passes the self-test.  If not, try right-clicking on your device and selecting 'Reset Device'.  You can then use the test panels to test the analog input, analog output, digital, and counter operation of your device.  These test panels make direct driver calls to your devices, eliminating the possibility of there being a problem in your LabVIEW code. 

Another thing you could try is the Online E-Series Diagnostic Utility.  This utility will systematically test the functionality of your card, and generate a report of its findings.

Let us know your findings from the test-panels in MAX and the E-Series Diagnostic Utility, and we can do some further troubleshooting from there.

Regards,
Travis Gorkin
Applications Engineering
National Instruments
www.ni.com/support
0 Kudos
Message 2 of 2
(2,098 Views)