Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Conceptual questions about Error-50103

Go to solution

First, I've reviewed most of the posts on the same error and still not understand what is going on.

Second, I’m using the DAQ USB-6003, DAQmx 19.0, LabVIEW 2019 and Windows 10 computer. I’m not using NI-MAX or DAQ Assist.

I’m working in a program that must uses two analog outputs (ao0 and ao1) simultaneously.

  • setup 1: ao0 defines the position of one linear motor using a waveform array (continuous, regeneration mode) inside an event structure
  • setup 2: ao1 defines the flow of one proportional solenoid valve (on-demand, writes Analog DBL 1Chan 1Samp) inside one specific while loop
  • setup 3: ao1 defines the flow of one proportional solenoid valve (on-demand, writes Analog DBL 1Chan 1Samp) inside another specific while loop

Well, sometimes the setups need work simultaneously, i.e., setup 1 and setup 2, giving me the error -50103. I've looked at the following page for guidance but I’m not sure about what I’m doing wrong and if I understood the issue. I suspected that my program could fit in cases 1 or 3 from the link.

Follow are my questions about each case:

Case 1: Failing to properly clear a task and release its resources.

When I’m using the ao0 and ao1 together, they must to work continuously. I'm not able to stop, clear and recreate the tasks if I’m using a while loop (ao1) or a regeneration mode (ao0).

Case 3: Using multiple tasks to access the same physical channels on a data acquisition board.

I’m not using the same physical channel at the same time, I’m using ao0 and ao1 at the same time.


I found some comments on knowledge base that confused me, i.e., in a post from 2004 I found:

“Some problem with the internal circuitry on the board that not allowed to have more than one task running (simultaneously) of the same type (like Analog input) because the internal circuitry is already reserved”. My comments: the “type” for me is not clear, would be a device? physical channel? Sometimes I see the term resource. What exactly does “type” mean?

In a post from 2012 I found:

"Case 6: Concurrently running two or more analog input or analog output tasks.  This error can also be thrown when a program explicitly calls multiple tasks performing the same type of operation at the same time. As with the other two cases, this produces a situation where multiple independent tasks are concurrently attempting to access the same resource. Even though the tasks might be using different channels, this is still a conflict because they require use of the same analog to digital converter and sample clock. To resolve this issue, combine all operations of the same type into the same task. For DAQmx 7.3 and later, it is possible to do this even with multiple types of analog input if you use multiple DAQmx Create Channel VIs". My comments: this conflicts with the case 3 (recent version), because shows that is not possible to use different physical channels. I don’t understand.

My program is huge and complex, and I can’t imagine how to nest everything in one while loop to get around this error.

Any comments, suggestions or information will be highly welcomed.



0 Kudos
Message 1 of 3
Accepted by topic author AndreaCruz

You actually have multiple resources being shared between the two tasks: the clock and the AO mux.


Solution 1: Figure out how to do everything with a single task.  This can become difficult due to update rates.


Solution 2: Use another DAQ for the second task.

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 2 of 3

Hi Crossrulz, now it's more clear for me.

I'll work on your suggestions.



0 Kudos
Message 3 of 3