Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

AO task in a Closed-loop Errors: -200018 and -200016

Hello,

 

I currently have 2 Ethernet NI 9237's and an NI 9201 module connected to a cDAQ-9172 USB chassis, all three of which I am using to read in voltages. In a LabView VI I'm designing, I have an AO Voltage task that is entirely contained within a while-loop: it is created, writes voltage values, and is stopped/cleared several times within a loop. This AO Voltage task is connected to an NI 9263 module which is also connected to my USB chassis.

 

I've attached a simple version of the part of my VI that gives errors when you run it: although the correct voltage values are sent through the AO task, I receive either error -200018 or -200016. In addition, performance is a bit flaky: sometimes when I run the program, nothing happens, as if the correct voltages are not sent through the AO task initially at all.

 

I've searched some threads and I'm thinking perhaps my sample rate is too high for the AO. However, I've tried reducing it but that didn't seem to help much.

 

I think the problem is in the VI I wrote, not the hardware I have. I'm using LabView 8.6. Is there a simple error in my VI that I've not noticed? Please let me know as soon as possible.

 

Thanks in advance,

 

Anthony

0 Kudos
Message 1 of 2
(2,338 Views)
I'm not sure what the Mathscript node is writing to the the buffer but the error implies that you are not regenerating the buffer with enough samples before it requests the data. I recommend increasing your buffer size to a larger size than your current value of 2.
Message Edited by ManLongAtNI on 01-08-2010 04:23 PM

Regards,
Glenn
0 Kudos
Message 2 of 2
(2,291 Views)