LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

The Distribution Kit Builder is Looking for the NI Variable Engine in an old distribution, cant find it and fails to build

Solved!
Go to solution

 

 I am unable to build a distribution kit because the builder appears to have saved a path to the NI Variable Engine which is not valid.  I appear to have the NI Variable Engine installed.   There are NI Variable Engine 2.5.0 .xml files loaded in on my computer (See attached for listing of drivers loaded).  I do not seem to be able to break CVI's Link to my past installers for getting drivers.  I've tried creating a new installer but had the same trouble. 

I am running a 64 bit Laptop with Windows 7, building a 32 bit application, running CVI 2010.

0 Kudos
Message 1 of 12
(3,859 Views)

Hello Chill,

 

Are you able to successfully build any distribution with or without having the NI Variable Engine  2.5.0 or NI Variable Manager (under Build » Distribution » Manage Distributions » Edit » Drivers and Components tab) enabled as a part of the distribution?

 

If possible, can you copy your project to another development machine to see if this is isolated to one machine or reproducible on a second?

Regards,

Shawn S. | NIC
Instrument Driver/IVI PSE
National Instruments
0 Kudos
Message 3 of 12
(3,836 Views)

When you're prompted for the ATAHM distribution, it looks like you have it, and you're providing the path, but there's some discrepancy between the one you're providing and the one that was originally installed. I can't really explain why that might be.

 

I would recommend trying to have CVI use a different distribution (other than ATAHM) as the source from which to pull NI Variable Engine 2.5.0. You can do this by editing your installer, going to the Drivers & Components tab, finding NI Variable Engine 2.5.0 in the list, and then pressing the "Change Source..." button to the right of the list. This will allow you to specify a different distribution from which to source that component. Keep in mind that the distribution you switch to must have the exact same version of NI Variable Engine. This may be a bit of a trial and error process, but hopefully one of the NI distributions you have on hand will contain that version of the component.

 

Mert A.

National Instruments

0 Kudos
Message 4 of 12
(3,820 Views)

I've found that the installer will build without including the NI Variable Engine component, but I am concerned that my users will need it.

We can build the application with the Variable Engine included when we do it on a 32 Bit PC.  The path that is used on the other PC to point at the component installer is available and contains the NI Variable Engine on my machine (C:\Program Files (x86)\National Instruments\Shared\ProductCache), but when I use it as the source, it tells me no installer is available.  The only difference I see is the( x86) in the pathname.

0 Kudos
Message 5 of 12
(3,806 Views)

Good news. I was able to identify your problem as a known issue with a workaround. Refer to this Knowledge Base article: http://digital.ni.com/public.nsf/allkb/D182D2D4B7780574862577EC006156D5?OpenDocument

 

Mert A.

National Instruments

0 Kudos
Message 6 of 12
(3,801 Views)

No luck, The instructions for the fix say to replace the existing file with the one that does not match the original.  Niether of the revisions matched my original file, so I tried each of the revisions, with no luck.  Basically, now the symptoms are simply that it cannot find the NI Variable Engine installer.  I seem to have it in the NI Product Cache, but it won't accept that as a valid path to the component.  Attached are screen shots of the path and contents I am trying to set as the component source and the message I get.

 

 

0 Kudos
Message 7 of 12
(3,793 Views)

When you change the distribution source, you must provide a path to a distribution (because they have metadata that allows verification of the products included). The product cache is just a folder full of individual products, so you can't try to point it to one of those paths.

 

Can you please post your original version of this file:

 

NI .NET Framework 2.0 Language Pack x86 Installer {F8ECD2D6-659C-49EB-8454-5F8F7B526FCF}.xml

 

Are you seeing a different error in the Build Log now? If you are seeing different symptoms now, please describe them or post an image.

 

Mert A.

National Instruments

0 Kudos
Message 8 of 12
(3,785 Views)

File attached.  I had to add the extension .doc so it would allow the upload.

The problem has not changed, but I cannot get the same error message, because I cannot find a distribution that it will take.  What is the default path to the NI Variable Engine distribution?  What does one who never built a distribution do to access this file?

0 Kudos
Message 9 of 12
(3,778 Views)
Solution
Accepted by topic author chill

The default path is the path to whatever distribution installed NI Variable Engine on your machine. For example, if it was installed from a Driver Disk, the path would probably be D:\. However, from the images you originally posted, I can see that you were being prompted to provide the path to one of your earlier ATAHM distributions. It was looking for it at this path:

 

c:\Users\chill\Documents\Development\AATAS\ATAHM\distributions_ATAHM\ATAHM Oct 24 2011\

 

Do you still have that distribution? If you can point it to that distribuiton, you should be good.

 

Now back to the error you were seeing... Your version of that .NET manifest file matches (except for the version number) Revision A from the Knowledge Base, so you should try replacing it with Revision B (and rename it to NI .NET Framework 2.0 Language Pack x86 Installer {F8ECD2D6-659C-49EB-8454-5F8F7B526FCF}.xml). Make sure you restart CVI after swapping the file. I would expect that to solve your problem. If it doesn't, you'll have to let me know what the new issue is, or if you're somehow still seeing the same error message.

 

Mert A.

National Instruments

Message 10 of 12
(3,773 Views)