LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

vmware labview

Experts,

Does anyone here run LabVIEW inside a virtual machine?

My OS of choice is Linux, but for a multitude of reasons I am forced to use Windows. XP is not too bad actually, it just cannot compete with a properly configured Linux system!

So at the moment I run WinXP inside a VMWare Workstation 6.0 virtual machine, and I have successfully installed the demo version of LabVIEW 8. Everything seems to work ok, but of course I am not doing anything with DAQmx or any other hardware involved. I suppose that is just not going to work as there are no virtual DAQ drivers?

Is anyone in a similar situation? I really don't want to have to dual-boot into Windows just to use LabVIEW.

Maybe the solution is to give the Linux version of LabVIEW a try, but then I am worried about being able to support customers who have Windows LabVIEW installations...

Thought anyone???
0 Kudos
Message 1 of 12
(7,318 Views)
Hello,

As long as you don't use hardware its fine. USB and Ethernet work, at least in VMware Server edition.

Further we had it the other way around, We developed on Windows for a linux target. The Windows code was ported and built in a LabVIEW for Linux that was running in a VMware server instance. The built executable was transferred to the Linux target.

But if you are developing for Windows users on a Windows platform it should just work fine.

Regards,

André
Regards,
André (CLA, CLED)
0 Kudos
Message 2 of 12
(7,299 Views)
Hi nrp,

Tomi Maila posted a couple of article on his blog about virtualization, I suggest you have a look there.

expressionflow.com

Hope this will help

We have two ears and one mouth so that we can listen twice as much as we speak.

Epictetus

Antoine Chalons

0 Kudos
Message 3 of 12
(7,297 Views)
Hi,

I am not virtualization expert by any means, but I believe it should be possible to use the
hardware also. I have read that one use for virtualization is that the system admins try
different configurations on a virtualized OS before they deploy everything to a real OS.

When you use virtualization software to load an OS, you have computer hardware working,
like CD-ROM drive, floppy disk drive, ethernet card etc. DAQ hardware shouldn't be any
different.

So, I think you should be able to install the DAQ card drivers for virtualized windows, you just
have to save the configuration to hard disk somehow.

If you decide to try this, please post your results here. I'm interested in this topic.
0 Kudos
Message 4 of 12
(7,291 Views)

Just another curious bystander wanting to see how this goes if attempted.

I've been trying to think of a way to get away from using a Windows OS on our test stations. IT department here likes to assault any Windows box that is plugged into the network with updates and virus scans. I understand the need to protect the network, but it is interfering with our ability to run tests so VMWare might be an interesting option.

 

-- Jase

0 Kudos
Message 5 of 12
(7,284 Views)
A lot of the hardware goes through a vitualization layer. In reality, a lot of the hardware you are talking about is not directly accessible directly. an example is the ethernet. You go through a layer that the vitural machine sees. The USB port may be the best bet. Even though you go through a virtualization layer, you might be allowed to control the device directly.
0 Kudos
Message 6 of 12
(7,278 Views)
Thanks for all your replies.

I have my doubts about non-USB DAQ hardware ever working in a virtual machine as VMware would have to provide drivers which interface with the host OS DAQ drivers. I do not see this happening any time soon!

I have bad experience with USB in a virtual machine though, I tried to update my ipod shuffle when it corrupted itself. Of course the update is a windows application, so I tried running it in a virtual machine (VMware workstation 5.something), and it toally nuked my ipod.  Took much effort and cursing to get the ipod alive again! (Had to use a real Windows installation).

USB DAQ hardware probably wouldnt need its flash updating so may be safe to try!
0 Kudos
Message 7 of 12
(7,272 Views)
Update (for anybody who was following this discussion)

I have Linux as guest OS, installed WinXP in a VMware virtual machine (host is dual core 2 (2.4 Ghz) laptop with plenty of ram, fast enough...) and then installed LV8.5 evaluation inside windows.

2D acceleration inside the windows guest seems to be fine, you can normally tell if everything is working by taking a window on the screen and dragging it around quickly  If it is all smooth then the drivers are properly installed. Non-scientific, sure, but I have found its a pretty good indication of performance. This seems to be working as I would expect it.

LabVIEW mostly works, except some very annoying behaviour. Some of the animations seem to take forever to render. For example, if you double click on a terminal on the block diagram, then when the front panel opens there is a decreasing grey box drawn around the associated control. This takes about two seconds to render in the windows host, and it is very jerky. Also, if you switch the palettes to the old LV 7 style, then if you click on a sub-pallete to go deeper into the nested structure, nothing happends until you move the mouse slightly, after which it displays the sub pallette. Then if you click the up arrow to go back to the parent it again takes a few seconds to draw the transparent grey box around the new menu item. Pointless animation and its so frustrating. If you select the new style pallettes then everything is fine! (one more reason to get used to them I suppose).

I have tried changing all the LV and windows settings with various combinations, but nothing really helps too much.

The actual performance within the VM seems fine, I have not actually done any back to back tests though.

This is all quite frustrating as I have to run Windows LV, and I really enjoy using Linux as my primary OS, and dual booting between the two is a dead-end street as far as I am concerned.

Anybody still interested in this? Or even better, any NI RnD people with suggestions on magical ini file definitions to turn off pointless animations within LV???

cheers
nrp


0 Kudos
Message 8 of 12
(7,183 Views)

Hello,

I try to use a crio inside a VM with LV 2010 - my Real PC is a windows 7, my VM is a windows XP -

I can ping the crio but I don't see it in MAX... I haven't FIREWALL and ANTIVIRUS turn on... Any suggestion?

0 Kudos
Message 9 of 12
(5,764 Views)

Hi fabio.intel,

 

As this is a relatively old thread now, I suggest that you will receive a much better response if you post it in a new thread. You can then link this forum post in your new thread.

 

Best Regards,

 

Christian Hartshorne

NIUK

0 Kudos
Message 10 of 12
(5,699 Views)