LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

simulation interface toolkit: SUB VI not executable error

Hi;

I have a real-time application where I model things in Simulink and use Simulation Interface Toolkit to carry out hardware-in-the-loop simulations. As a real-time target, I am using NI-PXI8106 with NI-PXI6251 DAQ card on it. Up until now, I was able to run my code just fine. However, for some reason, my vi didn't work today and gave several errors such as:

 

SubVI NI_SIT_sitclient.Lvlib:RVE.vi: SubVI is not executable

Details:The SubVI is not executable. You must fix all error in the subVI before this VI can run.

 

SubVI NI_SIT_sit Init Model.vi: SubVI is not executable

Details:The SubVI is not executable. You must fix all error in the subVI before this VI can run.

 

This is just few of many error that I received...In the details section of the error list window, the error statement are usually like the following:

 

SUBVI not supported for current target..

Type not supported in the current target...

 

The only thing that changed since the last time I ran this program with success is the IP change of the target machine..However, when I use Measurement and Automation tool, I am able to access my target machine (PXI8106) without a problem...Maybe there are some certain rules for IP settings on the PXI target? ...I can provide the details of my new IP configuration numbers if necessary...

 

I also  reinstalled the SIT 5.0 on the target machine but It didn't do the trick. I am wondering if there is anyone out there who can help me out with this problem..

Thank you so much!

Kind Regards.

 

0 Kudos
Message 1 of 6
(2,923 Views)

I am wondering If there is anyone who can help me with the problem in the previous post. Again, my previously-working SIT generated code doesn't work for some reason. The error messages are as in my previous post in this thread. The only thing that changed since the last time the code was run is the IP address. However, my IP assignment seems correct, as I hava access to my real-time machine with MAX just fine.... In terms of my configuration, Windows Vista, Labview 2009, SIT 5.0. Real time target PXI 8106 with NI-PXI6251 DAQ card in it.

I feel vey frustrated so any help will be greatly appreciated.

Kind Regards,

0 Kudos
Message 2 of 6
(2,892 Views)

What happens if you put the IP address back to what it was originally? I know it sounds trivial, but if it starts working again you can issume it's an IP thing, and if not you know you have to dig deeper! (sorry, I can't really help any more than that!)

 

I'm having similar problems but with the driver VI. As soon as I map an I/O to an SIT port and hit run, the error 1003 "Driver VI not executable" appears.

0 Kudos
Message 3 of 6
(2,852 Views)

Hi there,

 

I was just wondering if you did manage to solve this problem. I'm a new user and have recently started using the Simulation interface toolkit. I have created my model using Simulink and used the real-time workshop to convert it to a .dll file. I tried to run it on labview and it seems to build it on the realtime target, however as soon as map it to the hardware (using a NI BNC-2111,It's just a bunch of analog inputs and output which I have connected to a voltmeter), a dialog box pops up with the the following error:

Error 1003 occurred during host VI initialization: SIT_test1.vi >> NI_SIT_sitclient.lvlib:sit Init Model.vi >> NI_SIT_sitclient.lvlib:sit Connect to Target.vi

<append>=========================

Simulation Interface Toolkit:  The driver VI (SIT_Test_Driver.vi) is not executable.

 

Check the following:

1) You have not modified the driver VI.

2) You properly installed SIT and any necessary driver software on the target.

3) The target has not been locked from Measurement and Automation Explorer.

Do you want to launch the SIT Connection Manager dialog box and reconfigure the simulation?

 

 

Please look at the JPEG picture attached below to see how the error looks on my monitor.

 

Thanks

 

0 Kudos
Message 4 of 6
(2,723 Views)

Hi Mikil,

 

There are a couple possible reasons for this error. Before checking those, however, were you able to follow the process for Configuring a Real-Time Target to Run the LabVIEW SIT Server

 

Are you able to run the driver VI on the RT target? Then can you run the host application on your host?

 

All the best,

Fred Visser -- SystemLink R&D -- National Instruments
0 Kudos
Message 5 of 6
(2,703 Views)

Dear Mikil How are you.

 

Unfortunately I have exactly the same problem:(    Did you find the solution ?

 

I was wondering if you could share with me how you did it .Smiley Wink

 

Thank you so much 

0 Kudos
Message 6 of 6
(2,069 Views)