LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

file dialog doesn't show any files

Ok, now i'm totally confused:

Because i don't wanted to post my whole program (first of all it's too big and second it's a commercial software and i don't want the code to be public) i've created a new vi, which excludes the concerning code. To my astonishment, this code worked fine. Furthermore it allways showed the correct file dialogs according to the "use native file dialog"-setting (even when i called the file dialog programmaticaly and not from the "file path"-control).

After searching for differences in the 2 pieces of code i've decided to just delete the "file dialog"-function from the corrupt code und insert it again over the functions-pallete. To my great surprise everything works fine now (it shows all files & it shows the correct file dialog according to the "use native file dialog"-setting.

I really don't have any clue what the problem was, but it seems to work fine now, so you can forget this thread 😉

thanks a lot & regards,

mike

ps.: I wonder that i haven't mentioned it before, but my LabView-Version is 7.1
0 Kudos
Message 11 of 17
(626 Views)

A just-in-time possible solution: In case you wired a "pattern" input to the File Dialog VI, make sure to include a wildcard character, i.e. "*.txt" rather than just ".txt".

0 Kudos
Message 12 of 17
(395 Views)

"Just too late"?  By twelve years?  😄

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 13 of 17
(392 Views)

@billko wrote:

"Just too late"?  By twelve years?  😄


14!

0 Kudos
Message 14 of 17
(381 Views)

I know! Can you beat that? 😄

Native Americans have been waiting for justice for the last 500 years, and it still hasn't come. What's 14 years in comparison?

 

Seriously, though, I had exactly the same issue with exactly the same VI the day I posted my response. This is how I came across this post in the first place. And if it still occurs in LabVIEW, and the thread still comes up on Google all these years later, I see no reason not to post to an old thread. IMHO not doing so is the Internet's most annoying convention ever, and I commend NI for not sealing old threads shut.

0 Kudos
Message 15 of 17
(354 Views)

I was more interested in the play on words than disparaging your remark.  I'm sorry if you felt you had to defend yourself.  That wasn't my intention to criticize at all.  🙂

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 16 of 17
(345 Views)

2024 here to thank you for your help.  I just lost a couple of hours to this one....

0 Kudos
Message 17 of 17
(46 Views)