LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

compact fieldpoint web control problem

Solved!
Go to solution

Hi,

 

I have a vi written for the CFP-2110.  It reads values from a set uf CFP-AI-110 analog input blocks and writes values to a cfp-do-401.  The program has two timed loops, one to read and record values at 6 hz, and another to control three outputs on the DO-401 to move a cylinder back and forth for some lifecycle testing.

 When I run the program during development on the PC it works fine, stops at the end of the cycles I set, etc.  When I build and set it to run at startup, and connect to the CFP-2210 with a web browser, it also runs fine and stops like it should as long as a remain in "control" of it on the web browser.  However, when I start it, then release control and just monitor it, it will not stop like it should.  The controls on the User interface indicate that iot stopped, but the cycling keeps going and it keeps counting.  As soon as I do a request control in the browser, it stops as it should.

 

What is the difference between "controlling" and monitoring when it comes to program execution?  I plan to leave this running unattended and I really need it to stop on time.

 

Thanks for any info that might pertain to this. 

0 Kudos
Message 1 of 7
(1,776 Views)

Update.

 

Seems that when monitoring only, when I set the property node "value" of the control, the control appears to change, but the actual values does not in the program.  When I "request control", the value then changes.  If I re-load the web page, the controls "indication" goes back to the original state.

 

If in my program I write a False to the property node of a switch control, the control will appear to turn off, however, apparently the value it supplies continues to be True.  If I re-load the web page, it appears to turn back on.  If I do a request control, it appears to turn off and the values is then False.

 

Weird huh? 

 

 

0 Kudos
Message 2 of 7
(1,773 Views)
This is well-documented behavior.  Property nodes that are updated prior to establishing a connection with a remote front panel do not actually update.  See the LabVIEW manual or for more detailed information, see this page or search for "remote front panel property node" within the NI site.
0 Kudos
Message 3 of 7
(1,756 Views)
Solution
Accepted by topic author zener

Thanks,

What I did to resolve this is create local variables from the controls I needed to operate programmatically and write to them.  Instead of using the Value property node.  It works fine now.  

Message 4 of 7
(1,754 Views)
Glad to know you got it working.  In general you should avoid using property nodes in embedded RT applications since such applications don't actually have a front panel until you establish a remote connection.  As a result, if there's no front panel connection, your property nodes will return an error.  I once ran into this when using the "Controls" property of a cluster to read the labels of each item in the cluster - it worked fine in the development environment but not as an application because without a front panel the property node was invalid and generated an error.
Message 5 of 7
(1,751 Views)
If I am using shared variables, could I use those in place of the local variables and/or property nodes for updating my display?
0 Kudos
Message 6 of 7
(1,500 Views)
No.  Shared Variables are not supported on RT.  This is because of how the RT series boards communicate through the RT Proxy. TCP/IP is the recommended method of communication.
Message Edited by George P Burdell on 11-17-2009 06:51 PM
Regards,

Mike S
NI AE
0 Kudos
Message 7 of 7
(1,459 Views)