LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

analog output to analog input

Hi Naama,

 

So without the filter I have 2 problams:

1) error 200272- which I don't know how to solve (increase buffer size et cetera)

Error 200272 is about the sample rate being too low…

 

2) I don't know why it only do one cycle of analog output (hence the sine wave at the frequency 20KHz)

Did you examine the DAQmx example VIs explaining how to output an analog output signal with regeneration? Does that example VI work for you?

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 11 of 18
(631 Views)

Hi GerdW

 

Error 200272 is about the sample rate being too low…too low? but my analog output signal is 20KHz, and my sampling is 100KHz. It's 5 time bigger. My error is 200279

 

Did you examine the DAQmx example VIs explaining how to output an analog output signal with regeneration? Does that example VI work for you?It didn't work this is why I have modified the VI. 

 
thanks again,
Naama
0 Kudos
Message 12 of 18
(627 Views)

I think I have solved the first problem, but now the problem is that the data is new all the time in the graph and I want the data to display continually.

 

any thoughts? 

thanks in advanced,

Naama.

0 Kudos
Message 13 of 18
(610 Views)

and the attached VI

 

it says no filter but it is with filter

0 Kudos
Message 14 of 18
(608 Views)

Hi Naama,

 

data is new all the time in the graph and I want the data to display continually.

A graph only shows the data coming with the wire - it has no in-built history buffer (in contrast to a chart)!

When you need this history you should either use a chart or built your own history buffer with a shift register…

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 15 of 18
(597 Views)

Hi GredW,

 

thank you very much for your response. 

 

I have tried to put a chart but it showed me the same results. 

please if you can elaborate on the shift register and creating a buffer (I am new in labview so anything will help).

 

I read about queue and the producer consumer and I have tried to do a VI with that, but it also showed the same results. 

I have attached the file. 

 

thanks in advanced,

Naama.  

0 Kudos
Message 16 of 18
(596 Views)

Hi Naama,

 

there is no chart in your VI, just graphs…

 

Try this to append your waveforms:

check.png

Keep in mind: limit the waveform length to reasonable size to avoid heavy memory consumption and UI slowdown…

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
Message 17 of 18
(593 Views)

Hi GredW,

 

I will try this....

thank you so much!!!!!! 

Naama

0 Kudos
Message 18 of 18
(591 Views)