Showing results for 
Search instead for 
Did you mean: 

Writing shared variable (Modbus), Error code : -1967353900

Go to solution

Hi all,


I am currently editing a LabVIEW program to help run an experiment for a Master thesis. I was ready to build the program into an .exe but after installation of some additional software I started getting the following error code when trying to write some shared variables: 


Shared Variable in<APPEND>
This error or warning occurred while writing the following Shared Variable:
\\My Computer\Modbus-lib\000033
Valve seq module


Here is the section of the block flow diagram where the error occurs:error.JPG



I was wondering if anyone had any ideas what the error code relates to? Perhaps I am still missing some software?










0 Kudos
Message 1 of 6
Accepted by topic author amarsh

Using the Help -> Explain error menu item in LabVIEW I get the following:


Error -1967353900 occurred at an unidentified location
Possible reason(s):
LabVIEW DSC:  (Hex 0x8ABC8FD4) The Modbus I/O server failed to allocate a serial port. Ensure that the specified serial port is available.


Make sure that no other application is using the serial port that the Modbus server is configured to open.

LV 7.1, 2011, 2017, 2019, 2021
0 Kudos
Message 2 of 6
Accepted by topic author amarsh

all solved


so essentially after I installed the software it was trying to write the shared variable without actually having physical connection with the valves. Everything worked once the vi was run from the experiment pc.


Not entirely sure why labview ran the code without error beforehand previously though, must have simulated it somehow.


0 Kudos
Message 3 of 6

Hello amarsh, the two solution marked seem to be quite different, which one is good?

What do you mean with "physical connection with the valves"?

LV 7.1, 2011, 2017, 2019, 2021
0 Kudos
Message 4 of 6

Sorry i pressed the wrong comment by accident!

By 'physical connection' I mean that the was no cable connecting the valve controller to my laptop.

0 Kudos
Message 5 of 6

Thanks for your help though, it really helped troubleshoot the problem

0 Kudos
Message 6 of 6