LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Webserver: open subVI front panels

When a VI is viewed in browser thru Labview webserver, and it opens a subVI with "show front panel when called", will the subVI be shown in the browser? Will it be a popup? If not, can this be achieved somehow?
0 Kudos
Message 1 of 5
(2,736 Views)

Hi There,

 

Thanks for your post and I hope your well today.


I feel these two links maybe of use to you,

 

Can A SubVI Open Its Front Panel When Using Remote Panels?

http://digital.ni.com/public.nsf/allkb/E313D1D88CE14FDA86256E6A006B28ED?OpenDocument

 

Linking to a SubVI's Remote Front Panel from a Top-Level VI

http://digital.ni.com/public.nsf/websearch/DB4C3B13F329293686256F380061419D?OpenDocument

 

Please let me know your thoughts, 

 

 

Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
Message 2 of 5
(2,718 Views)
Thank you. They're a bit contradictory; first doc says all subVIs will popup, second doc says they won't, but i think it refers only to dinamically loaded and reentrant subVIs.
0 Kudos
Message 3 of 5
(2,692 Views)

Hi,

 

I wanted to say that I felt this article was correct..

 

Can A SubVI Open Its Front Panel When Using Remote Panels?

 

It was written this year, compared with 2007. I am getting to test this out...

 

Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
0 Kudos
Message 4 of 5
(2,677 Views)

Hi,

 

I just wanted to confirm that using the web services the subVI front panel will not appear in the same web-browser page. 

 

To achieve this you have two options, as the knowledgebase articles were trying to explain - not very clearly I will admit, and hence I will edit them going forward.

 

1) Use a Sub Panel window to open the VI within the Front Panel of the Main VI.

2) Create a link on the webpage for the main (top-level) vi  to the subVI html file.

 

These both work for me. 

 

Just remember that the text you need to  add in the footer/header wherever in the main html file to create the link should be something like this, 

<a target="new window" href="SubVI01.html">SubVI Title</a>

 where the SubVI01.html is the name of the file the web tools tool created for my subVI.

 

 The steps then are best followed here,

 

Linking to a SubVI's Remote Front Panel from a Top-Level VI

http://digital.ni.com/public.nsf/websearch/DB4C3B13F329293686256F380061419D?OpenDocument

 

Tips:

1) Make sure niwebserver CONF file has the correct Document Root - I couldnt get the default one labivew\www to work.

2)  Make sure the application configure settings file has WebServer.Enabled=True

3) Make sure the exe is running on the target machine - I just did this all locally.

4) During the exe build make sure you select to always include all SubVIs and html files you've generated. 

 

 

I hope this helps, but if you have any problems getting this to work please post back - as I have the setup working currently. 

Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
0 Kudos
Message 5 of 5
(2,661 Views)