LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to create an executable in LabVIEW 2010

Hello,
I have an application written in LV8.2 which turned smoothly.
I passed under LabVIEW 2010, and I get an error when creating an executable.
 
 **********************************************************************
The error occurred at 1: Node method in 

AB_Build.lvclass:Copy_Files.vi->AB_Application.lvc​lass:Copy_Files.vi->AB_EXE.lvclass:Copy_Files.vi->​AB_Build.lvclass:Build.vi->AB_Application.lvclass:​Build.vi->AB_EXE.lvclass:Build.vi->AB_Engine_Build​.vi->AB_Build_Invoke.vi->AB_Build_Invoke.vi.ProxyC​aller

 
Possible reasons:
 
LabVIEW: An input parameter is invalid. For example, if the input is a path, it may contain a character that is not authorized by the operating system like? or @.
=========================
NI-488: Command requires GPIB controller as a controller in charge.
 
Method Name: Linker: Write To File Info
 ***********************************************************************


After some research, I isolated the sub VI that was causing the problem.
 
  
VI.JPG 

 


 
It is a. Net that can launch a pdf file
 
If I put this functionality directly into the main diagram (without a sub VI), I get the following error:


 ********************************************************************** 
The error occurred at 74: Node method in 

AB_Build.lvclass:Copy_Files.vi->AB_Application.lvc​lass:Copy_Files.vi->AB_EXE.lvclass:Copy_Files.vi->​AB_Build.lvclass:Build.vi->AB_Application.lvclass:​Build.vi->AB_EXE.lvclass:Build.vi->AB_Engine_Build​.vi->AB_Build_Invoke.vi->AB_Build_Invoke.vi.ProxyC​aller

 

Possible reasons:
 
LabVIEW: Memory or data structure corrupt.
 
Method Name: Linker: Write To File Info


 **********************************************************************

 
Note: I made a small app that uses only the VI and I do not have PB.
 
Someone there a line of research?
Thank you in advance

0 Kudos
Message 1 of 2
(3,682 Views)

Hello dca,

 

Thanks for posting on National Instruments forum.

 

You can find here a post for a similar issue.

    Benjamin R.


Senior LabVIEW Developer @Neosoft


Message 2 of 2
(3,636 Views)