Showing results for 
Search instead for 
Did you mean: 

Some issue when create exe

Go to solution
hello everyone I had created a project and it can be running successfully in compile environment. But when i create a exe, it can’t running. I used some vis of ZeroMQ ,and i have add dlls to my project. The error is as follows: Error 13 occurred at Call Library Function Node in>>>Executor.lvlib:Executor.lvclass:Execute test>Executor.lvlib:Execute test vi>Actor Framework.lvlib:Actor.lvclass:Receive>Actor Framework.lvlib:Actor.lvclass:Actor>Executor.lvlib:Executor.lvclass:Actor>Actor>Actor Possible reason(s): LabVIEW: Failed to load dynamic library because of missing external symbols or dependencies, or because of an invalid file format. ========================= Shareable board exclusively owned.
0 Kudos
Message 1 of 4
Accepted by topic author Griffin-Ning

Hi, may I confirm some details with you first?

  1. Is it “running the .exe” and “running compile environment” both are same computer?


If no, maybe in current computer does not have sub VI /document which you used in application, so the application failed to call.


Remember just put all needed VI/document in the same directory with application.exe.


  1. Check all the file path in block diagram, use VI such as “Application directory” to create relative file path instead absolute file path.


  1. You may check the following solution to find the missing dependencies.

Error 13 at Call Library Function Node When Trying to Open DLL in LabVIEW - National Instruments (ni...


We can discuss at here again if you face any difficulties during your troubleshooting.

0 Kudos
Message 2 of 4

Tks you for your suggestion,i found that i lost some .dll and some path error like what you said.

And now i can create the .exe successfully.I hope that we can discuss more about LabVIEW or some interesting tools here,tks you again!😀

0 Kudos
Message 3 of 4

Hi Ning,


I am having the same error while creating executable. My OS Win-10 64 bit

Could share the dlls what exactly you included in your application.

 I tried to include following dlls.


Your answer would be greatly helpful

0 Kudos
Message 4 of 4