Showing results for 
Search instead for 
Did you mean: 

Software or Hardware troubleshooting?

I'm using an NI cDAQ-9172 chassis with LabVIEW 2016. I have been using a VI to test a product for over a year now, totaling several dozen successful tests. Each test runs for 3 seconds. I have one while loop which has four channels using NI 9482 which starts/ends the test of the system by opening/closing valves. This loop is stopped after three seconds using Elapsed Time. A notifier is used to stop the second while loop, which contains a DAQ assistant with eight channels. I acquire data at a rate of 1000 Hz using an NI 9211 and three NI 9215. On my last three tests, the data acquisition stopped for 1-2.5 seconds (never for a consistent amount of time, or at a the same time) while the system we are testing ran properly (that is, the valves opened/shut appropriately). The timestamp on the output file shows gaps in the data; for example, I have data for time 0.000 s - 0.700 s, and the next data point is at 1.700 s. If I run the program without anything flowing through the valves, the data acquisition works as normal. Where should I begin troubleshooting? Is it more likely a hardware or software problem? I cannot attach a VI as it is proprietary. Thanks.

0 Kudos
Message 1 of 3

So, the question is what has changed from when it worked properly to when it stopped working properly?


If you didn't change anything in the code, then I would start suspecting hardware.


Why would anything flowing through the valves change the behavior?  What is flowing?


What if you developed a simpler version of your VI that allows you to just cycle the relays and valves and see if they meet the timing requirements called out by your simpler VI.

0 Kudos
Message 2 of 3

I have received a lead that suggests hardware and I'm working on troubleshooting that now. Hopefully it solves the problem!


Thanks for the response, I wish I could have deleted the post before you took the time.  

0 Kudos
Message 3 of 3