LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Serial Port Framing Error

Hello, I am new to this forum and wondered if someone may have the answer to a labview problem I am having.

 

I have written a VI that accesses the serial port of an Embedded PC (Kontron Module) when booting up from a USB boot drive. I am examining the debug output for a particular string output and then selecting different options based upon what Im receiving, such as programming the BIOS by sending out a string value "1" to the port etc. This VI was developed earlier this year and worked perfectly with no errors on this particular pcb. Now though it seems that framing errors are being detected. It isnt the pcb since I have now got one on that I know works. The pcbs come in 2 versions one of which works perfectly and this one that doesnt.

 

has any one got any ideas as to why this may be happening?

 

regards

 

John

0 Kudos
Message 1 of 6
(4,674 Views)

99% of the time that I see a framing error is due to the Baud Rate being wrong/different.  There are many other settings you need to make sure are also correct.  It would not surprise me if the serial communications got changed between models without people telling you.

 

I would also probe the TX and RX lines to make sure they look correct.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 2 of 6
(4,650 Views)
Thanks for the reply. I should mention that this vi works perfectly with another variant of this pcb, the difference being the epc module and has worked with this specific pcb. Is it possible for the visa functions to have become corrupted? Am using labview 8.6.1 but am not sure it is the problem. The port seems to be outputting a large number of junk and control characters. Is it possible to filter these?

Regards
John B
0 Kudos
Message 3 of 6
(4,639 Views)
Framing errors are hardware issues. Have you done any basic troubleshooting such as using a terminal emulation program such as hyperterminal or putty? You say the device is booting up. Perhaps the clock for the UART is not stable yet. Does the error go away after a brief time?
0 Kudos
Message 4 of 6
(4,634 Views)
Sometimes when tracing with slow motion set to on it actually returns valid output but this is also very random and the framing error appears after the first serial read.
0 Kudos
Message 5 of 6
(4,620 Views)

Works okay with the light bulb on?  Time to post some code...

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 6 of 6
(4,604 Views)