LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Serial Commands

Solved!
Go to solution

Why did you bother to attach without making any changes. If you had simply done what I had said to do, your problem would have been solved and you could mark the thread as so.

0 Kudos
Message 11 of 15
(597 Views)

As Dennis said, your conversion from the number to a hex string is wrong.  The function you used converts the number into an ASCII represenation of the number.  So 16 would become "0010".  Those are ASCII characters, not a hexidecimal representation.  What you need to do is change that constant to a U16 and then use Type Cast or a Flatten To String to change the representation of the data into a string.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 12 of 15
(577 Views)

Hi,

 

I'm testing to attach a VI (just crossrulz' snippet)...

No, cannot attach "*.vi" files. Still need to rename to "*.vit"...

 

Well Dennis, I too can't attach VIs. Still the same problem like several month by now! You can check the history of that problem in this thread...

 

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO
0 Kudos
Message 13 of 15
(556 Views)

I can. Using Chrome.

0 Kudos
Message 14 of 15
(501 Views)

Ok. So that problem seems to be browser related.

 

But I guess that forum should support more than just Chrome. And that problem exists now for several FF versions and is (or: should be) known to NI&Lithium...

 

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO
0 Kudos
Message 15 of 15
(482 Views)