LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Script error using the Labview web browsing vis

Hi all. 

I did a program for a client in which i was displaying a browser in the front panel of the main vi.

This browser is needed in order to acces a web cam via a specific url. This program was working fine (it was first intalled in December 2018) but today my client called me and showed me the error i am attaching to you in this thread and the web page of the camera is not displayed anymore. It is related to a script error (maybe a json error?) and i don't really know how to work around it.

The program is running on a windows 10 machine and the client enabled the automatic updates a couple of months ago. 

 

May this error be related to those automatic updates? Also the main browser on the client's pc was set to Edge. I chenged it to Internet Explorer which should have ActiveX compatibility.

Download All
0 Kudos
Message 1 of 4
(1,133 Views)

Hi andrea123,

 

One behavior of the IWebBrowser2 ActiveX Control is that it does not rely on the Windows setting used for opening urls in a browser. The default browser setting is independent and likely should continue to use a modern browser such as Edge, Firefox, Chrome, etc.

 

The forum post Script Error While Opening HTML File discusses some ways for choosing the Internet Explorer version loaded by IWebBrowser2 and links to a third party blog that gives more details about specifying the IE version.


Milan
0 Kudos
Message 2 of 4
(1,115 Views)

Hi Milan, thank you for your reply!

I tried to add a registry key following the instructions of the blog you sent me (see the attached pic) but nothing seems to change, i still have the same script errors.

In the image you can see the key i added: C2018013_Calpeda.exe with an exadecimal value of 0x2AF9 (Internet Explorer 11. Webpages are displayed in IE11 Standards mode, regardless of the !DOCTYPE directive.).

Did i miss something?

 

Andrea

 

0 Kudos
Message 3 of 4
(1,058 Views)

Dear all

 

I tried different things to get rid of this java-script errors (changed registry, etc.). Nothing worked. What finally worked for me was to set the silent property of the browser control to true. Perhaps this is a solution for others too.

 

Nevertheless, I hope NI supports one day a modern browser engine which can be implemented into VIs.

 

Best regards

Andy

 

Innoworks_0-1642757485291.png

 

0 Kudos
Message 4 of 4
(259 Views)