Showing results for 
Search instead for 
Did you mean: 

Running a Xenics Xeva in LabVIEW


I am trying to run in LabVIEW 2012, but I encounter some problems. runs on two modes: USB and Framegrabber. 

If I run it on the Framegrabber-mode I get following error: (-1074396120) IMAQ .
This error can be traced all the way down to, where we now have the error code: (-1074397163). 

Running the USB-mode will give me the same error code number (-1074396120) and the text IMAQ Get Image Pixel Pointer. The error can be traced down to IMAQ GetImagePixelPtr.


As far as I understand it seems like the program somehow doesn't get any input from the camera. However, the camera works well in Xeneth and also the runs without a hitch. 
I am inecxperienced in LabVIEW and have absolutely no clue on what to do. I have not written or changed any of the mentioned .vi's, so as far as I know they should be in their original state.


I hope you can help.

0 Kudos
Message 1 of 3

Hi Sig_Bor,

Unless the VIs you are talking about are in vi.lib, you will have to upload them so we can even start to check for a problem. I even have vision acquisition software installed and don't have them. Can you upload

0 Kudos
Message 2 of 3

Hi again,

I am sorry for the delayed answer, but I had to spend some time teaching myself LabView in order to understand anything. I realised my last question was idiotic because I simply hadn't connected anything to the Now that I am older and wiser I have encountered a new problem I hope maybe you could help me with:

I have written a program called which initialise a Xeva camera, sets some properties, snaps and saves a photo before shutting it all off again. It can run on two mods, Framegrabber or USB mode, but the latter leads to an error in the program. 
I am trying to snap a photo in the USB-mode. Everything seems to be in perfect order until I reach My problem is that I don't understand what happens in the third frame of the Flat Sequence Structure in, and where my error occurs. It always runs the XC_GetFrame and the second case structure argument will be "true", leading to error 5201. Where it now says "Copyframeproblem" there was a sub-vi called, but it could not be found on the computer. My guess is that if I were to have a proper sub-vi here this could solve the problem, but I have no clue on how that .vi should look like or what it should have as an output. 



0 Kudos
Message 3 of 3