LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Replication and Deployment (RAD) Utility Application Image retrieval Error

Hello All,

 

I am trying to create an application image from my cRIO-9074. However it doesn't work. I do have Ni-RIO driver 3.51 as the same version as the one I installed in the cRIO-9074. I used LabVIEW 2010 with the version of 16.0 RAD Utility. 

I also installed the NI system configuration 16.0.1. 

But it doesn't work.

I have attached the error message image.

Please help me out.  

Thank you very much!

0 Kudos
Message 1 of 3
(1,818 Views)

Hi Jacob911,

 

This seems like a connection problem so I'd suggest a few things to try. 

1-) Make sure that the target doesn't have "Inconsistent IP settings" either in the deployment or development computer

2-) Use a sample program, Get and Set Real-Time System Image.vi. You can find this by opening LabVIEW, going to Help>>Find Examples. When the NI Example Finder window opens, click on the Search tab and search for "Get and Set Real-Time System Image". Note that there is no progress bar showing that the VI is running, but if you look at the block diagram, you will note that the program will end when it is done. If this errors out with the same issue, we know that RAD isn't the problem.

3-) Also if your system has any passwords, that could also be causing this issue. This is something that we can test without needing to wait for a time that we can turn off the cRIOs. Once you are connected to the same network that the cRIO is on, you can go to Internet Explorer, and navigate to the IP address of the device. You should be able to do this just by entering the IP address in the IE URL field, and hitting enter. There is a login option at the top right-hand side, near the National Instruments logo. Click that, and try entering "admin" for the username, and leave the password field empty. Hit enter. If you aren't logged in, the issue could be with the fact that the system requires a password. 

4-) Make sure that the subnet mask is the same in both the cRIO and PC

 

Regards,

PedroR

0 Kudos
Message 2 of 3
(1,753 Views)

Hi Pedro,

 

Thank you for the replay. I figured it out with my other laptop. I only installed LabVIEW 2010, NI-RIO 3.5.1, and RAD utility with the version 2.1. And it's worked. I am thinking about the RAD version should be capable with the LabVIEW version. because I installed 16.0 RAD before, and it is for LabVIEW 2016. 

 

I would like to try to use your idea to test on my desktop to see if it's worked or not.

 

Thanks again!

Regards,

Jacob

0 Kudos
Message 3 of 3
(1,742 Views)