Showing results for 
Search instead for 
Did you mean: 

RealTime - Failed to load shared library

Hi everyone,


I'm working with the cRIO 9074 system and programmed a ANC application with LabView. Yesterday I tested my application the first time but it didn't work as expected. Because of my testing- and developing-place are different I have to carry the cRIO-System and my laptop between them. So I just disconneted the powersupply and the networkcable. Then 10min later I tried testing again but I got an error. Today in the morning I got the same error like yesterday, which is the following one:


"Failed to load shared library AdaptivFilter. Ensure that the library is present on the RT target. Use MAX [...]"


I reinstalled the NI software (more than once) how I was adviced with MAX but it didn't fix the problem, maybe the AdaptivFilters-library was not included.


In the project-explorer a library called "NI_AdaptivFilter.lvlib" is included and I also found the path of the file on my harddrive.


It drives my nuts that it worked and than 10min later it doesn't.

I hope you could help me, thanks.


Download All
0 Kudos
Message 1 of 1