Showing results for 
Search instead for 
Did you mean: 

Re: Save & Recall setup

Good afternoon to all,
I am a new user to LabVIEW Robotics 2017 and I have recently started writing my first program. However, I have faced some issues along the way. Firstly, I am unable to recall the saved setup from the oscilloscope as show in both the Image (1) and Image (2) below. 
In image(1), I am directly using the command : RECAll:SETUp and I have followed the instructions as stated in the programmer manual, yet there are still errors popping up, as shown in error (1). In image(2), I used the current VI path function to obtain the path name, followed by strip path and build path to get the ideal filename, then after that wire straight to VISA write. Same thing, errors still popped up as shown in error (2).
If there is anyone who has done something similar or who has knowledge of this, I will greatly appreciate your help and advice.
Thank you! 


0 Kudos
Message 1 of 33

I was thinking that there was a LabVIEW Robotics Forum where you might find many fellow Robotics users, but didn't find it.  There is a LEGO Mindstorm Forum, and also a pretty extensive LabVIEW Robotics Support page with lots of links that might be helpful ...


Bob Schor

0 Kudos
Message 2 of 33

Most of us ignore pictures of block diagrams.

"If you weren't supposed to push it, it wouldn't be a button."
0 Kudos
Message 3 of 33

Good evening Bob,
Thank you for the links that you have provided, much appreciated! However, I am still unable to find a solution to the problem. 
Do you have any potential suggestions to save and recall setup from a DPO 4034B, apart from using the RECAll:SETUp and SAVe:SETUp commands or, using getting the VI path, strip and build array to it? I am open to alternative solutions as well! 


0 Kudos
Message 4 of 33

Sorry, Lynn, I thought this was a Robotics question.  I had no idea what a DPO 4034B was, so I searched the Web and found links to a Tektronix Digital Phosphor Oscilloscope, and said "This can't be right", but, of course, it was.  Did you follow the directions on Page 34 of the manual, "Connecting your Oscilloscope to a Computer"?  The manual recommends Tektronix's Open Choice software:  "OpenChoice lets you use your MS-Windows computer to acquire data from your oscilloscope for use in an analysis package that runs on your PC, such as Microsoft Excel, National Instruments LabVIEW. or a program of your own creation."


Have you followed the procedures as outlined in the manual?  Are you using TCP/IP, GPIB, or Ethernet?  [You may have answered this in your original post, which I don't have in front of me, so forgive me if I'm being redundant ...].  Did you see if the Oscilloscope (or its Port) showed up in MAX?


Bob Schor

0 Kudos
Message 5 of 33

 Hi all, the two VIs as attached are the versions that I have tried, but they are unable to work! If anyone has ideas on what went wrong or anything to improve on, I will greatly appreciate it. 

Hi Bob, I forgot to mention that I am using a USB to connect the oscilloscope to one of the working ports of my laptop. The connection works well as I have previously been able to run other programs as well. And yes, the port showed up in MAX.

I have also attached a copy of the DPO Programmer manual.


Thank you


0 Kudos
Message 6 of 33

SCPI comands usually refer to files on the instrument, not the PC.  Does the directory you are trying to use exist on the scope?  Is the directory Read-Only?  Have you tried creating your own directory, making it read and write friendly, and then saving and recalling setup files from there?  (Read the manual carefully to see if there is a way to use files stored on PC, or what the default path is on the scope.)


One tip I found useful with a couple of scopes is to first manually try saving a file, browsing to that file and looking at the directory structure.  Then manually recall the file.  If possible on your scope enable the SCPI/GPIB (named differently on every instrument!) command window which gives you an echo of the command that was just executed.  In this way you might get the exact syntax you need.  Or it might be that the SAVE/RECALL functions have a predefined root directory which you might need to set before making calls to files with pathnames relative to that root directory.  A quick peak at the manual suggests you can use a default (scope directory) by not supplying a directory.  I did npt investigate further to see about saving to PC.


Try that and if it doesn't solve your problem I look at the manual more closely.



0 Kudos
Message 7 of 33

I have provided the 2 versions of VIs that I have tried to recall and save the setup retrieved from the oscilloscope, but there are errors to the program. Any advice or suggestions are greatly appreciated.
Hi Bob, the connection is good as I have ran other programs using labview and the oscilloscope. I forgot to mention that I am using a USB cable and yes, the port appeared on MAX.

I have also attached a programmer manual for Tektronix DPO 4034B on the types and usage of commands.
Thank you

0 Kudos
Message 8 of 33

Thanks for attaching the manual.  As I looked at it, I had an "Aha!" moment -- I think I've seen something like this before in the LabVIEW Forum, say within the last year, maybe?  So I did a Web search for DPO LabVIEW, and got a bunch of hits, including Example code from NI (published on the Web in 2018, but originally published more than a decade ago for LabVIEW 7, very curious ...).  There are videos, the manual is pretty detailed, I would think that with a colleague or two (testing almost always goes better, in my experience, if you do it with someone else, if for no other reason than you'll keep each other sane when things don't work quite right ...).


Bob Schor

0 Kudos
Message 9 of 33

Hi Lynn1965,


Page 2-329 of the manula you posted clearly shows the right path format..




Note that it uses / forward slashes not \ backslashes as you were using.  I think making this change to your Diagram 1 code should solve your problem.


Also there is a VI in the driver that your code is using calles "Save-Recall" found in the driver's Public\Utility\ directory.  While it saves setups to scope memory rather than files it might be good to try that too.  Its a less permanent solution, but might get things moving.



0 Kudos
Message 10 of 33