LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Keithley 2400 source meter

Hello all,

I tried to controll a keithley 2400 source meter with Labtracer using a NI GPIB-USB-HI card but when I run the test is send me this error message: "There was ab error reported on Visa Read in Query. Test aborted. Error code: -1073807339"

is this card (NI GPIB-USB-HI) able to controll keithley 2400 source meter ?

the keithley 2400 source meter screen show "REM TALK" during the running of the program,

I installed NI488227 in my computer (windows XP) and also "Agilent Connection Expert", this later also show no possibilty to connect with the Keithley meter, I attached a file for  "Agilent Connection Expert".

Any help is appreciated

Thank you by advance

 

0 Kudos
Message 1 of 16
(5,988 Views)

Follow the preliminary steps to first check if the device is able to communicate via the GPIB-USB convertor.

navigate to: Start>>National Instruments>>NI 448.2>>Interactive control.  Use this utility to query the GPIB device for some standard commands for e.g.: *IDN?

There is also a GPIB analyzer in the above path which you can use to verify the device connectivity to the system.

 

Also for communicating the with 3rd party GPIB devices always enable " NIVisa Tulip.dll" which will help recognising the device in max.  Look at the picture to enable this option in max.

post back for queries

 

 

With regards,
JK
(Certified LabVIEW Developer)
Give Kudos for Good Answers, and Mark it a solution if your problem is solved.
Message 2 of 16
(5,975 Views)

Installing the Agilent software was not at all necessary and may be the cause of your problem. The Agilent software would be used if you had an Agilent GPIB controller. You may have installed some software that replaced something required for an NI controller. Why did you think you needed the Agilent software in the first place? I would suggest you remove everything related to Agilent and reinstall all of the NI software.

 

JK,

 

I'm going to have to disagree with you about tulip. It's only necessary when you want to use a third-party GPIB controller with MAX and LabVIEW. It does not affect communication with instruments.

Message 3 of 16
(5,955 Views)

JK  and Dennis,

Thank you for your answers,

I tried to communicate with the meter by the method suggested by JK but I failed, when I used the GPIB analyser it send me this message:"A GPIB Analyser interface was not found, you still may use this application to view previously captured data. Refer to the NI-488.2 Readme file for a list of supported analyser interfaces for your operating system" and the window for  GPIB Analyser was opened with this title: "Unknown/Missing GPIB+card""

I removed everything related to Agilent and reinstalled NI488227 again but still the problem persist,

Thank you

0 Kudos
Message 4 of 16
(5,936 Views)

You can only use the analyzer if you have a '+'  type card that includes the analyzer functionality.

 

At this point, I really don't know where and how you are getting an error. Your very first step is to use MAX to verify that the driver is installed correctly and the controller is recognized. These are the basic steps in your installation instructions. Then, once the controller is recognized and passes those tests. Do not do anything until this works correctly. If it does work, right click on the controller and select 'Scan for Instruments'. If that fails to find your instrument, post back.

Message 5 of 16
(5,922 Views)

Yes it fails to find the instrument, attached is a print screen,

thank you for your help

 

0 Kudos
Message 6 of 16
(5,907 Views)
If you have another GPIB instrument, try connecting only that to the controller. If you are using a cable to connect between the USB-GPIB and the instrument, try a different cable. Look at the instrument configuration and verify that GPIB is enabled.
Message 7 of 16
(5,903 Views)
Yes another instrument  was detected and I attached the MAX screen print
0 Kudos
Message 8 of 16
(5,895 Views)

This time I tried again with the Keithley 2400 source meter, it was detected (I don't know what was changed with before) but it didn't respond to a query, and the same problem like before remain for Labtracer (same error message)

 

0 Kudos
Message 9 of 16
(5,883 Views)
You might have a bad instrument.
0 Kudos
Message 10 of 16
(5,868 Views)