LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem running two parallel while loops

Solved!
Go to solution

I think it might have something to do with taring?  Check the settings in the paramter section of the OpMan.  I think you are SO CLOSE right now...

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 61 of 95
(289 Views)

Hi Bill,

     Sorry I could not get back to LabView for a few days. How exactly Taring. I have browsed through the settings on the device and the taring option is set right, i guess. Could you explain what you meant so I can be sure what i am looking for?

 

regards,

avi0111

0 Kudos
Message 62 of 95
(263 Views)

It just seemed that it was returning real zeroes, as if taring was offsetting your weight to zero.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 63 of 95
(251 Views)

Hi Everyone,

    Sorry I have been inactive for almost a month now, the reason being I was waiting for the new scales to come in. I believe the new scale has better documentation. But I am facing similar problems;

1) Issue with formatting the string specifier before I pass it on to the waveform chart and then to a spreadsheet. See attached VI and Screenshot.

2) The VISA Write does not pass on my command to the scale. This scale comes with a host of settings for RS232 communication. Currently set at Print mode. Should I switch it to some other setting?

 

PS: I have switched to Labview 8.2 professional licensed version.

 

Regards,

Avi0111

0 Kudos
Message 64 of 95
(226 Views)

And the User manual just in case.

0 Kudos
Message 65 of 95
(224 Views)

I'm replying just to let you know that I've seen your post.  I'll see what I can look at tomorrow.  🙂

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
Message 66 of 95
(213 Views)

@avi0111 wrote:

Hi Everyone,

    Sorry I have been inactive for almost a month now, the reason being I was waiting for the new scales to come in. I believe the new scale has better documentation. But I am facing similar problems;

1) Issue with formatting the string specifier before I pass it on to the waveform chart and then to a spreadsheet. See attached VI and Screenshot.

2) The VISA Write does not pass on my command to the scale. This scale comes with a host of settings for RS232 communication. Currently set at Print mode. Should I switch it to some other setting?

 

PS: I have switched to Labview 8.2 professional licensed version.

 

Regards,

Avi0111


1)  Try using this format string to get the timestamp as well as the force:

%<Date;%m/%d/%Y;Time;%H:%M:%S>T;Gross;%f g;

 

2)  You probably will need to put it into a command mode.  I haven't looked through the manual on how to do this.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
Message 67 of 95
(208 Views)

I think Cross is right on the money about both.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 68 of 95
(186 Views)

Hi Crossrulz,

    With the format specifier given in your post I get an error saying too many "%" in a format specifier. Is there a way in which I can completely neglect the time stamp and date? I need only the weight value in grams.

 

regards,

avi0111

0 Kudos
Message 69 of 95
(174 Views)

Hi Billko,

    I have a question regarding the VISA write section of my program. The Command i need to send to the scale for immediate scale reading recovery is: "SI"CrLf

    Now, Since the Visa serial block at the beginning of the program has a CrLf connected to it, does that mean that any command sent by the program to the device has the CrLf attached to the end of it? If so, my command will be: "SI" only.

    If thats not true then it will be: "SI"CrLf.

    I am searching through the documentation on ways to switch the command modes ON. I will keep you guys updated.

 

Regards,

avi0111

0 Kudos
Message 70 of 95
(164 Views)