LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

License experation

I have a EthernetIP add-on already activated, but now it calls for license expiration, I think it was permanent, 

if not, how can I reactivate?

 

I'm using LabVIEW 2019 SP1,

 

i have the serial number, but the aplication for activation does not work, calls for not being a valid code,

0 Kudos
Message 1 of 6
(506 Views)

If you can get the 16-digit computer ID you could try generating an activation code here with your serial number:

https://www.ni.com/nilg-activate/jsp/customer_activate_details.jsp

 

I'm fairly certain that addon is only sold as a permanent license.  

Message 2 of 6
(492 Views)

More details...
weird thing is that the License manager seems to be all right.

Eduardo_Rendon_0-1695751276672.png

however, the VI does not run due license issue,

 

0 Kudos
Message 3 of 6
(481 Views)

already do that without success, however...

This is a case where the solution comes when you explain to problem to other person, giving the problem sense to be write down...

 

the version of the add-on updates to the newest ( 2023 ) as the license is permanent it goes straight without problem on license manager,

however, the application I have is coded on version 2019, which was kicked out from the newest version,

 

removing the 2023 and install the 2019, and the app runs again,

0 Kudos
Message 4 of 6
(468 Views)

LabVIEW support software only supports the matching LabVIEW version plus the 3 prior versions.  So that would make sense.

 

If you have decided to stick with LabVIEW 2019 then be sure not to install anything from 2023 or later, whether it's the Ethernet/IP addon or anything else.

0 Kudos
Message 5 of 6
(461 Views)

Hi

 

The problem here was actually the result of NI's new Toolkit and Driver concept. In that concept there is no more a four year back compatibility limit. It is replaced by a promise of compatibility for any newer LabVIEW release.

 

This is excerpts from the Readme : 

 

NI-Industrial Communications for EtherNet/IP 2022 Q3 Readme

July 2022

 

Application Software Support

The following table lists the application software versions, including service packs, supported by NI-Industrial Communications for EtherNet/IP. If you are not using NI application software, refer to Microsoft Visual Studio Support.

Application Software Versions Supported by NI-Industrial Communications for EtherNet/IP
LabVIEW 2022 or later
LabVIEW Real-Time Module 2022 or later

 

Updated LabVIEW Compatibility Policy

When installing NI-Industrial Communications for EtherNet/IP, the "NI-Industrial Communications for EtherNet/IP Support for LabVIEW" package will be recommended if you have already installed LabVIEW 2022 or later and installs to the LVAddons directory. This package supports applications using NI-Industrial Communications for EtherNet/IP with LabVIEW 2022 or later.

LVAddons directory location: C:\Program Files\NI\LVAddons

 

The previous 2021 release still offered the 4 year back support concept ( 2018, 2019, 2020, 2021 ).

 

LabVIEW 2022 Q3 is the first version to support the new concept.

 

Regards

0 Kudos
Message 6 of 6
(449 Views)