LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labwerx LabSSH Library error 402429

Solved!
Go to solution

Hello, I am receiving the error mentioned above when attempting to establish an SSH connection. Our LabVIEW software was updated from 2012 to 2022, and since then, every module in our application works except those using this particular library.

 

Here are more details of the error message:

 

error 402429 labSSH.lvlib: Error Converter.vi

Possible reason(s):

Bad internal library usage : Null ‘labSSH Connection’

 

Relevant system information:

-LanVIEW 2022 Q3 32-bit

-LabVIEW SSH Toolkit version 2.6.3.0

 

Has anyone run into this issue before, and know what could be the source of the problem? I would have thought that the upgrade would provide all he necessary packages and framework.

 

Thank you in advance!

0 Kudos
Message 1 of 3
(760 Views)

Do a Web search for LabVIEW SSH Toolkit.  You will learn that LabVIEW has SSH capabilities starting with LabVIEW 2021, and NI has no responsibilities or knowledge of third party Toolkits such as LabSSH.  I think what NI is saying is that you should "do it with the tools that come with LabVIEW 2021 (and 2022))" -- I think there are some links you can find in the Web articles.

 

Bob Schor

0 Kudos
Message 2 of 3
(719 Views)
Solution
Accepted by topic author Baxter2023

Thank you for your response. That's an understandable position for NI. We found out that the library needed to be force re-compiled after upgrading. 

0 Kudos
Message 3 of 3
(709 Views)