LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview with FTDI D2XX drivers?

Highlighted
Is there anybody who used LV with the FTDI D2XX drivers for USB ports?
0 Kudos
Message 1 of 82
(19,532 Views)
Highlighted
I'm also starting to use these drivers to control my USB device. I have the dll and using "Call Library Function Node" I can acess the functions from the dll. That's all I know for now...

If you now something more please tell me

Regards,

Pedro
0 Kudos
Message 2 of 82
(19,413 Views)
Highlighted
Yes,

I am developing a interface library toolkit that interfaces to the FTDI chips using the D2XX.

The first tool kit is for a FPGA board that can be directly programmed and control from the USB. Also the start up eeprom can be programmed from the same USB port.
0 Kudos
Message 3 of 82
(19,352 Views)
Highlighted
Thanks for the reminder in this old thread!

I wrote in the meantime soem wrapper VIs for the D2XX.DLL routines. They may be of some help for someone, so here they are (LV 7.0):
Message 4 of 82
(19,336 Views)
Highlighted
I am using Labview with FTDI D2XX drivers. i have done the FT_open,FT_write and the FT_close but i cannot communicate with the FT245bm chip till now.
0 Kudos
Message 5 of 82
(19,246 Views)
Highlighted
HAve successfully used FTDI FT245RL with labVIEW using d2xx functions.Guys let me know if u need any assistance
Message 6 of 82
(17,679 Views)
Highlighted
Who can help to make work FTDI D2XX drivers in LabView 7.1? The examples FTDI provide to do function completely. I'm usin' 245R. Do not understand how they organize RD and WR signals. RXF and TXE are explicitely there, but RD and WR are not found unless they are included in C call funcrion when writing and reading the data. 
0 Kudos
Message 7 of 82
(16,887 Views)
Highlighted

Just hoping htat the thread is still alive.

 

I am using FT232R chip with my LabVIEW(8.5) program.

I am just using the basic functions Like FT_OPEN, CLOSE, QueueStatus, READ, WRITE etc.

 

each function works fine except the READ one.

I have set the Bytes to Read = 1600. and after executing the READ function, when i read Bytes Read it gives the O/P = 1600.

However, the string returned by the ReAD function comprises of only 1 Byte.

 

What could be the problem??

 

 

Ritesh 

0 Kudos
Message 8 of 82
(16,752 Views)
Highlighted

Hey Ritesh,

 

Have you tried the example on the FTDI site:

 

http://www.ftdichip.com/Projects/CodeExamples/LabVIEW.htm

 

(Example 1)

 

It is a bit hard to be specific about your problem without your VI or hardware. The 232 chip is generally no problem. If you are only getting 1 byte back it may be because you are either only asking for one back (FT Read Byte Data VI, 'Bytes to Read' terminal), or it may be because there is only one byte in the queue. You can use the 'FT Get Queue Status' VI to load the correct queue size in to the 'Read Byte Data VI, as per the example. Remember the FTDI will time out if it does not receive the expected number of bytes, returning only what it has.

 

0 Kudos
Message 9 of 82
(16,747 Views)
Highlighted

Hi BlueTwo,

I tried with that example itself when i first used the FTDI VIs.

 

I am actually following the  same procedure as the one you suggested in your post.

I am using "GetQueueStatus" to check the no. of bytes and if the bytes>=1600, i read them using "FT_READ" function. Input to the Function(Bytes to Read) = 1600.

and the O/P returned by the Function(Bytes Read) = 1600. 

However, the output string contains only 1 byte.

 

This is what that looks so confusing. If Bytes Read return = 1600, then why the string contains 1 byte.

 

 

 

Ritesh 

0 Kudos
Message 10 of 82
(16,739 Views)