LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview runtime engine 7.1.1 installation failure - error 1402

I just installed Labview 8.2.1 on my PC running Windows Home Edition.

Then I attempted to instal NI-DAQmx 8.6. Near the end of that installation,
an error window opened with the following message:

"The NI LabVIEW Run-Time Engine 7.1.1 installation has failed with the following error:

Error 1402. Could not open key: UNKNOWN\OPC.ServerList.1\CLSID."

All firewalls were turned off as well as my anti-virus program. I completely
uninstalled the entire LabView 8.2.1 package and tried re-installing
everything again. No luck. Same error message.

Can anyone assist me on this issue?

phil
0 Kudos
Message 1 of 13
(5,770 Views)
 

Hi phil,

Thanks for contacting National Instruments.  I was looking into your question a little more about installing LabVIEW 8.2.1 and getting error 1402 and I think I have an idea that we can try.  I was just searching through our Knowledgebase database on www.ni.com and I found a particular article that may help you out.  I have provided the link below and all of the instructions are present in the document for you to follow.  If you have any more questions, please feel free to post back and we can go from there. Thanks!

http://digital.ni.com/public.nsf/allkb/7A99E891BDCBE3A88625715700516EE6?OpenDocument 

Regards

Noah R
Applications Engineering
National Instruments
0 Kudos
Message 2 of 13
(5,731 Views)
Hello Noah,

Thanks for taking the time to do some research.

Unfortunately, I had already searched this forum for error 1402 and found
the message you mentioned. I used Regedit to search for the offending key
but it wasn't present in the registry.

The suggestion at the end that I run Scanreg / fix won't work on Windows XP,
only Windows 98. My operating system is Windows XP Home Edition with all
the latest patches.

Do you have anything else that might fix this installation problem?

I went ahead and continued with the rest of the installation of DAQmx 8.6.
Most everything else seemed to install okay.

What will features of DAQmx 8.6 be crippled or broken if NI LabVIEW Run-Time
Engine 7.1.1 isn't properly installed?

phil

0 Kudos
Message 3 of 13
(5,724 Views)

Hi phil,

That is interesting that you were unable to find the offending key that the installation is having trouble with.  Do you have Administrator privileges on your computer? You may even want to try to log in as the actual Administrator itself to make sure that you have access to all of the proper registry keys.  Also, I was going to say that I do think you're right with Windows XP not having the Scanreg/fix function, but there are several free programs that you can download as registry checkers.  You may want to try one of those to see if you can find the key and give it the proper permission.

As far as the other part of your question, the Run-Time Engines are very important for LabVIEW to be able to run, but the 7.1.1 Run-Time Engine should not be affecting a LabVIEW 8.2 installation as it will use the 8.2 Run-Time Engine.  One thing that you can do is go into your Control Panel under Add or Remove Programs>>National Instruments Software and you can try and repair/modify your Run-Time Engine there.  If you already have the 7.1.1 Run-Time Engine on your computer, this is where it will show up so you can make any changes you want.  Also, if you go to www.ni.com and click on "Drivers and Updates" on the right, you will be able to find the Run-Time Engine there that you will need, but I would definitely try using a downloadable registry checker first before attempting to change any of the software that is currently on your computer.  As stated in the Knowledgebase article, this is actually an error from Windows saying that the registry key does not have the proper permission settings, so I am reluctant to say that downloading the new Run-Time Engine from our website will help much.  Please try some of these suggestions out and let me know how they work out for you. Thanks!

Regards

Noah R
Applications Engineering
National Instruments
0 Kudos
Message 4 of 13
(5,717 Views)
Hello Noah,

I'm the sole user, and hence also the Administrator on this system. If I start
Regedit and search for

OPC.ServerList.1\CLSID

no entry is found. However, if I omit the \CLSID and just search for

OPC.ServerList.1

I find several entries. I checked permissions for those and I am listed
as having full read/write access.

I should note, that since I am permitted to install this version on three
PCs, I did a complete install of LabView 8.2.1 and DAQmx 8.6 on
a laptop running Windows XP Professional. Both programs installed
without any problem.

Just out of curiosity, I opened Regedit on the laptop and searched
for

OPC.ServerList.1\CLSID

No entry was found on that machine.

Thinking that perhaps the DAQmx CDs that were supplied with my
USB 6008 hardware may have been defective, I downloaded that
program from the NI website. Running the downloaded software
produced the same error message.

Runtime engine 7.1.1 doesn't show up when I tried your suggestion
about using the Control Panel for repairing NI components.

I haven't yet tried locating an online registry checker.

My guess is that you are correct in thinking that the issue is a Windows
XP permissions problem, but I haven't had much luck in following that lead.

Since I have one PC where everything is functional I'll use this broken one
for miscellaneous activities.

If you have more thoughts on this please pass them along.

Thanks for you help.

phil
0 Kudos
Message 5 of 13
(5,707 Views)

Hi phil,

That's pretty strange that the directory is not showing up when you search for it.  For everything that I have seen in the past, using some kind of registry checker usually helps even if it is a downloadable version.  I have also had someone call in before that had a similar issue with the Run-Time Engine and what eventually fixed their problem was uninstalling both LabVIEW and DAQmx and then re-installing.  I understand if you are going to use the working machine, but if you do try a few more things on this same machine that you are having trouble with, please let me know how it goes and feel free to ask any more questions if you have any. Thanks!

Regards

Noah R
Applications Engineering
National Instruments
0 Kudos
Message 6 of 13
(5,698 Views)
Hello Noah,

One of the first things I tried was doing an uninstall via the Control Panel
Add/Remove Programs. Still got the same error message when reinstalling
DAQmx 8.6.

If I ever get this solved, I'll be sure to post the method that worked.

phil
0 Kudos
Message 7 of 13
(5,691 Views)

Hello,

 

I have exactly the same error with two diferent computers and I've not been able to solve it yet. Did you find the solution?

 

Thank you!!

 

Alex. 

0 Kudos
Message 8 of 13
(4,481 Views)

I have exactly the same problem when installing on Vista. Any solution?

0 Kudos
Message 9 of 13
(3,745 Views)

Hi Gunnark,

 

While Vista is not listed as a supported OS for the 7.1.1 runtime engine, you may want to look at the following KB to see if it helps any. 

 

Error 1402 During Installation of National Instruments Software

http://digital.ni.com/public.nsf/allkb/7A99E891BDCBE3A88625715700516EE6?OpenDocument 

 

Regards,

 

Michael G

Michael G.
Applications Engineer
National Instruments
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Self-realization: I was thinking of the immortal words of Socrates, who said, "... I drank what?"
0 Kudos
Message 10 of 13
(3,736 Views)