Showing results for 
Search instead for 
Did you mean: 

Labview GUI interface usb/virtual serial port from pic18f2550

Labview GUI interface usb/virtual serial port from pic18f2550



I doing project replace the hardware using pic. Since the GUI is labview interface, i not intention to switch to other software.

By modify the pic code from the cdc-emulator example,i able to do the serial read/write using hyperterminal and but not with the labview.

It prompt out the error

Error -1073807330 occurred at Property Node (arg 1) in VISA Configure Serial Port (Instr).vi

Possible reason(s):

VISA:  (Hex 0xBFFF001E) The specified state of the attribute is not valid, or is not supported as defined by the resource.


Look like i fail to configure the COM Port which is visualize as valid com port in device manager and i open the MAX, there's error show as pic attach.

I already try to create new driver .inf from the driver lizard and install it but still no luck.


I've been visit the microchip forum and view other ppl solution and look like they don't face this problem "Error configure port".


So, anyone can help me to solve this problem??

Attach also the main.c for the pic programming. I newbie in pic programming, possible the code is not completed.


thanks and regards,



0 Kudos
Message 1 of 2

Re: Labview GUI interface usb/virtual serial port from pic18f2550

HI all.

I meet the same error and need the solution, even some hint or direction will be helpfull

I have made composite device based on RoDeNtJe project ( dual cdc) based on 18f4553

it work well in hyperterminal. unfortunately i changed 3 PC with this project so:

it works perfect on winxp

it works on win7 32bits  ( limitation - transmitting for only 3 bytes at a time)

it works same on win7 64bits up to some day.  then the multiply error  (-1073807360)  start appear.


i think it happened after the USBSER.sys have been updated by windows.


0 Kudos
Message 2 of 2