Showing results for 
Search instead for 
Did you mean: 

Labview 2018 Application doesn't work on Windows 10 IoT Enterprise LTSC

I've tried to install an application with setup.exe (version Labview 2018) on Windows 10 IoT Enterprise LTSC (ARM 64).

However, I got a message said that this installer requires Windows 10 64 bit (version 1607) or newer.


When I checked Labview and Microsoft Windows compability, NI's Labview 2018 supports Windows 10 IoT Enterprise.

Also, I checked the Windows 10 OS version, and its OS shows that the version is Windows 10 21H2 whichi higher than what the exception message said.


I've also checked if the installer is 64 bit. And I tried both 32 bit and 64 bit both, but still the same message showed up.


So far, I could not find what the problem is. I could not even figure out that Labview 2018 actually supports Windows 10 IoT Enterprise or not.


Can anyone help me what the real problem is? I want to know if they are comptiable


Labview and Microsoft Windows compatiability:

0 Kudos
Message 1 of 2

LabVIEW is a Win32 application compiled for Intel x86/x64 CPU architecture and uses SSE2 floating point hardware features. Until recently Windows IoT Enterprise was an Intel x86/x64 only system too.

The Microsoft Intel CPU emulator does not support SSE emulation so your LabVIEW package couldn’t run on it even if you could install it.


Until LabVIEW 2015 or 2016 you could disable use of SSE in the Application Builder settings. But that is not possible anymore and use of LabVIEW on ARM hardware was never a supported feature with the exception of Raspberry Pi and Beaglebone Black through the Hobbyist Toolkit.

So use of LabVIEW on Windows IoT Enterprise was indeed fully compatible until Microsoft introduced an ARM version of that recently. Now that compatibility table needs a foot note explaining that limit.


Also, even if you could disable SSE instruction use in the Application Builder and trick the installer to install your application on the system, it will break down as soon as your application needs any hardware drivers like DAQmx. Those need to be native as the Intel emulator in Windows IoT for ARM does not work inside the kernel. And there are no ARM or ARM64 device driver from NI for Windows.

Rolf Kalbermatter
My Blog
Message 2 of 2