LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview 2011 SP1 crashed

Check the attachment.Why Labview is crashing?Its crashing after installtion and without running any code.Labview version is Labview 2011.

Please help me with this if any one get solution.I uninstalled and Installed saveral times but problem is same

Associate Engineer
Eaton Technologies Pvt. Ltd
0 Kudos
Message 1 of 9
(3,040 Views)

So is it correct that this happens everytime you start LV?

 

You should, if this is persistent even with re-installation, check your system for viruses. If there are non, try starting LV with anti-virus software and firewall disabled. Does it change the behavior?

 

Also, you might want to try a different source for the installer:

Either download one or take another DVD. Maybe your installer is corrupt.

 

hope this helps,

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 9
(3,027 Views)

What are the exact computer specifications (processor model, etc.).

 

What happens if you click "view reports"? Anything interesting? Did you sent the reports?

0 Kudos
Message 3 of 9
(3,018 Views)

Ive had similar problems but was when i had loaded the application i was developing (I was incorrectly using a fifo). WHen you uninstall has everything been removed. I seem to remember that you need a software tool to completly uninstall so the machine may not be as clean as you think when you reinstall labview

Please remember to accept any solutions and give kudos, Thanks


LV 8.6.1, LV2010,LV2011SP1, FPGA, Win7
0 Kudos
Message 4 of 9
(3,016 Views)

@Akiel wrote:

[..] I seem to remember that you need a software tool to completly uninstall so the machine may not be as clean as you think when you reinstall labview


I think you are referring to MSIBlast, which is not a real official tool.

Personally, i feel that MSIBlast is overrated. In fact, this tool only tracks for standard installation entries in the registry, just like "Add/Remove Software" in Windows Control Panel does. With Win 7 (even maybe before) you can uninstall a batch of software entries, so the last advantage of MSIBlast is obsolote as well.

Uninstalling NI software using MSIBlast or Add/Remove Software has the exact same effect. Installation done with any installer program might introduce registry keys which are not removed when uninstalling. These remaining keys bloat the registry and might be a reason for crashes/slow downs and other odd behavior of the system.

 

Keeping the registry clean is an effort, not many admins/users do master. There ARE tools available to help, but they have to be used with discipline, and once that discipline is broken, they are not helping out anymore. And sometimes, those tools remove used keys breaking still valid (installed and 'registered') applications. So they are no magic bullet.

 

That is most often the reason, why a complete system fomatting and re-installation is faster than uninstalling, using some *magic* tools but still have to manually administer the registry.

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
Message 5 of 9
(3,011 Views)

Sounds familiar, came from a conversation I had a number of years ago but couldnt get the details of what was left behind and what the tool did

Please remember to accept any solutions and give kudos, Thanks


LV 8.6.1, LV2010,LV2011SP1, FPGA, Win7
0 Kudos
Message 6 of 9
(3,005 Views)

Thanks a lot to all for your valuable replies.I formated PC once, Installed with another DVD but still problem is same.

Currently we changed PC and Installed on it.Now its running properly on it.But it was running on Previous PC from 6 months won't have any problem before.Still we are checking what must be the problem.

Associate Engineer
Eaton Technologies Pvt. Ltd
0 Kudos
Message 7 of 9
(2,975 Views)

Hi Norbert_B

 

When I install Labview for some time its working properly.It gets crashed within 1 Hour and we can not work further.as I previously talked with NI people and as per their suggestion I disabled Antivirus as well as Firewall.Installed with another DVD but still problem is same.Now we changed PC and Installed Labview on it.its running properly on new PC.

Associate Engineer
Eaton Technologies Pvt. Ltd
0 Kudos
Message 8 of 9
(2,974 Views)

Can you point out the differences in the systems (hardware/OS)?

 

You also might want to run a Scandisk and some RAM check on the affected system to make sure, that there are no hardware failures.

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
Message 9 of 9
(2,959 Views)