Showing results for 
Search instead for 
Did you mean: 

LabVIEW FPGA compile error

I get "an error occurred attempting to connect to this compile server. Details: NI-Farm: Farm server is not responding.  Be sure the specified hostname is correct, the server is running and configured to accept remote requests" when I try to compile LabVIEW FPGA VI.  This VI used to compile fine on LV 2011 and Xilinx tool 10.


My current environment is:

Windows 7 32-bit, LabVIEW 2012 SP1, Xilinx 13.4 SP1.


I've been using the same hardware, PXI-7854R.  I'm using "Use the local compile server" option to compile.  My questions are as follows:

1. Is my PXI-7854R supposed to work with the above mentioned OS, LV and Xilinx compiler versions?

2. Is NI-Farm supposed to be running in order for Xilinx compile tool to work?

3. How do I find out whether NI-Farm webservice is running locally?



0 Kudos
Message 1 of 12

You should not be using the compile farm feature unless you have actually set up a compile farm.


This would be two or more PCs that have been repurposed for helping to compile FPGA bitfiles by distributing the load.  Chances are, you are not using this.  Check your settings, and diasble anything related to this.  That should eliminate the error.

Machine Vision, Robotics, Embedded Systems, Surveillance - Custom Imaging Solutions
0 Kudos
Message 2 of 12

That was also my understanding, that I shouldn't be using NI-Farm since I don't have a remote compiler.  I never enabled the NI-Farm but why am I getting error message that mentions NI-Farm?  Where can I disable this?


Also from what I've read, compiler service runs locally even if you compile on the same machine.  At least that is my understanding of the compiler operation.

0 Kudos
Message 3 of 12

Well, I should note that while you may not have the NI LabVIEW FPGA Compile Farm Toolkit, a back-end component of the Worker\Server architecture we use for all compilations is called NIFarm. Even if you're compiling locally on your machine, the backend is mostly the same as if you were compiling to a remote Server/Worker.


The place I would start with is your Windows Services ([Windows Key] + r, then type 'services.msc' and hit [Enter]). Make sure the "NI System Web Server" is started and running. If it's not, try starting it and let us know if there is an error. Next, see if you can connect to 'localhost:3580' in your browser window. You should be able to get to the Web InterFace (WIF) for system configuration. If not, you likely need to adjust your firewall settings. Also, you may be able to find some useful information in workerLog.txt, niClientFarmLog.txt and niFarmLog.txt(C:\Program Files (x86)\National Instruments\FPGA\CompileWorker). Not all of these may be present on your system, but if you post them here, I'll take a look and see if I find anything interesting.


EDIT: And to answer your questions; yes, your software set looks fine and will be compatible with your 7854R, yes it should be, and the Windows Service and logs I mentioned above will tell us if it's running or not.


Message 4 of 12

NI System Web Server service was not running.  However, when I tried to start it, the following error message was displayed.


Windows could not start the NI System Web Server service on Local Computer.  Error 1075: The dependency service does not exist or has been marked for deletion.


I checked the firewall settings and all NI services were allowed, including port 3580.  I found KB article ( on repairing MAX to make sure all dependencies exist.  I'm still in process of repairing.


I also attached log files from farm worker.  Thanks for guiding me through troubleshooting.

Download All
0 Kudos
Message 5 of 12

Ok, the System Web Server not running is definitely the problem. Let me know how that MAX repair works out for you. If it doesn't, could you create a MAX Technical Report of your system for me?


0 Kudos
Message 6 of 12

I've been repairing MAX, LV2012 SP1, LV FPGA, etc but no luck.  I notice other NI services that are set to "automatic" but show the same 1075 error when I try to start them (mdns responder, application web server, pxi resource manager etc).  Also tried re-repairing LV2012 SP1 and LV FPGA but didn't fix the problem (recommended by another KB that stated system web server can be unregistered after a repair).


In what software is NI System Web Server included?  What are the other services that it depends on?

0 Kudos
Message 7 of 12

I uninstalled all NI software from my machine and installed NI Developer Suite 2013 DS2.  When it prompted for Xilinx tool disk I skipped it and instead installed Xilinx tool version 14.  After the reboot all the services (NI System Web Server, mDNS Responder etc) were running and I was able to start compiling my LV FPGA VI's.


Since I started with Dev Suite 2013 DS1 but ended up getting it to work with DS2, I do not know if DS1 caused the failure or not.  My guess is that complete reinstall to any version would've worked - I just decided to use the latest version that I received from NI.


Based on my search of this website, this is still an open issue some users were able to fix by reinstalling everything.

0 Kudos
Message 8 of 12

Well, sorry you had to spend so much time reinstalling, but that was probably faster than trying to hunt down the root cause anyway... I hope you enjoy the new features 2013 provides! Be sure to check out the Desktop Execution Node and Waveform Sample Probes with LabVIEW FPGA 🙂


0 Kudos
Message 9 of 12

I ran in to this myself yesterday. On a Core 2 Duo machine with 3 GB RAM. It took me 10 hours yesterday and 6 hours today uninstalling and reinstalling many combinations of different NI software components before I got my FPGA VI to start compiling.


I eventually uninstalled every bit of NI software I had on the computer, then upgraded to Feb 2014 Developer Suite and Device Drivers. I wasn't really at a point in my development process where I wanted to upgrade LabVIEW versions (I was trying to make a minor change to an application with several existing deployments running 2012 SP1) but I guess I am stuck with it now. I also threw in a few patches that NI Update Service told me were Urgent.


To add insult to injury, after I finished my epic uninstall and reinstall, the first compile attempt gave me an error on some missing files within C:\NIFPGA\programs\Xilinx10_1. 10.1?? I thought I was on 14.4 now! Time for a Hail Mary. I just tried deleting the Xilinx10_1 folder as an attempted cure for some kind of failed uninstall. It worked! It took a few minutes though for my palms to stop sweating from the dread of facing another NI install screen.

0 Kudos
Message 10 of 12