LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW 8.0 VISA troubles

Solved!
Go to solution

Hi Kevin,

 

As I said it is simple write/read VISA code and it worked when run separately but not within main VI for some reason. I disabled termination character configuration vi in order to let Read entire buffer.

BTW after installed older Run-time engine (2019) even this code does not work any more 🙂

 

Alex_Suhisky_0-1646242729738.png

 

0 Kudos
Message 11 of 19
(255 Views)

I just tried to download Labview 11 that NI also deleted from my computer together with v 7.1 and 8.0  🙂  and discovered that NI has moved to a subscription basis. So now I understand why There was a promotion that allowed to install evaluation version that wiped out all others... Also I understand why it was necessary to delete all the versions that had installed. Maybe because of the same reason my VISA does not work any more...
I think this is unfair. I've got all the previous versions without subscription agreement and now the new policy is applied to that software and I don't have anything any more?
VISA does not work any more on my computer.
I am very upset, folks.

0 Kudos
Message 12 of 19
(244 Views)

@Alex_Suhisky wrote:

I just tried to download Labview 11 that NI also deleted from my computer together with v 7.1 and 8.0  🙂  and discovered that NI has moved to a subscription basis. So now I understand why There was a promotion that allowed to install evaluation version that wiped out all others... Also I understand why it was necessary to delete all the versions that had installed. Maybe because of the same reason my VISA does not work any more...
I think this is unfair. I've got all the previous versions without subscription agreement and now the new policy is applied to that software and I don't have anything any more?
VISA does not work any more on my computer.
I am very upset, folks.


Sorry, I have to I call B.S. on this.

 

I have several version of LabVIEW installed and the new subscription licensing does NOT effect anything before LabVIEW 2022 (which is not even released yet) 

 

 

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 13 of 19
(239 Views)

I don't know what to say... Here are the facts:
1. Evaluation version wiped out all older versions.

2. I reinstalled Labview 8.0 from original CDs and my VISA does not work any more.

3. I am not able to download Labview 11 (I lost my original CD but I found the license number). It is greyed out and in addition description states that the latest OS it is compatible with is Windows 8. It also says: "Purchase or renew SSP, and register previously purchased software to access locked versions."

What part of it is BS?

 

0 Kudos
Message 14 of 19
(236 Views)
Solution
Accepted by topic author Alex_Suhisky

Briefly,

 

1. The boolean input for enabling a termination character only applies to Read operations.  If your device uses one, you should enable this and specify the correct character.  (By default, the config function uses a line feed = hex 0x0A = decimal 10).

 

2. Go to your constant that shows "PA\r\n".

    Right-click, choose "Visible Items->Display Style".

    Right-click, choose '\' Codes Display.

    Do you now see "PA\\r\\n" with double backslashes?  If so, you weren't actually sending carriage return and line feed characters to signal message termination to your device.  You were feeding a literal backslash, an 'r', a literal backslash, and an 'n'.  So your device didn't answer.

 

3. Search the forums for discussions about using "Bytes at Port".  Learn from them.   You don't want to keep doing what you're doing now.

 

 

-Kevin P

CAUTION! New LabVIEW adopters -- it's too late for me, but you *can* save yourself. The new subscription policy for LabVIEW puts NI's hand in your wallet for the rest of your working life. Are you sure you're *that* dedicated to LabVIEW?

(Summary of my reasons in this post, part of a voluminous thread of mostly complaints starting here).



Message 15 of 19
(233 Views)

BINGO!!!

Thank you, Kevin! Yes, I had double slashes!

I just got a response from that thing 🙂 I disabled termination character because the device answers with a few lines and each one ends with the termination character:

Alex_Suhisky_0-1646253844161.png

But you were right on money with the double slashes.

I owe you big!

Thank you again!



0 Kudos
Message 16 of 19
(224 Views)

Thank you all!

So the only thing I will have to try now is to get from NI my Labview 11 somehow  🙂

0 Kudos
Message 17 of 19
(221 Views)

@Alex_Suhisky wrote:

 

What part of it is BS?

 


This part

 

@Alex_Suhisky wrote:

There was a promotion that allowed to install evaluation version that wiped out all others... 


 

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 18 of 19
(216 Views)

I am not lying, buddy. It did.

0 Kudos
Message 19 of 19
(211 Views)