Showing results for 
Search instead for 
Did you mean: 

LINX I2C Problem with Arduino

I'm using Adafruit's BNO055 (9-DoF) and VL53L0X (Time of Flight) sensors for a class project. I'm having trouble reading in the values from both of those chips. I'm connecting both of those sensors using an Arduino Uno. The Arduino IDE is able to give a suitable reading while I'm having serious trouble even interfacing with LabVIEW. 


The VL53L0X has a default I2C address of 0x29 while the BNO055 has a default I2C address of 0x28. I have tried to convert and use those following address values to 41 and 40 (in Decimal) respectively, but it still does not give the information I require. I was hoping somebody could take a look at this and hopefully point me in a direction so I can learn and rectify the mistake.


Let me know if anybody requires any further information. I know the VI has a lot of information on it, but on the BLOCK DIAGRAM, if you scroll all the way down, the final while loop is where I'm facing my issues. I tried using 0d40 in hopes of reading in the 9-DoF values, but no luck. 




Message 1 of 2



Did you end up figuring out how to read the VL53L0X? I can communicate with my arduino, but can not get the data from the chip.  Any help would be greatly appreciated.

I attached my vi below.

0 Kudos
Message 2 of 2