LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with Accessing Application Due to Outdated LabVIEW Version

Solved!
Go to solution

Hello NI Community,

I am currently facing a challenge with an application that was developed using LabVIEW and VeriStand 2012. I have LabVIEW 2024 installed on my system, and when I attempt to open the application, I receive an error message stating that the LabVIEW runtime engine cannot be found and that the application requires a 2012 or compatible version of the LabVIEW runtime engine.

The exact error message is as follows: “Unable to find the LabVIEW runtime engine. COCKPIT requires a 2012 (or compatible) version of the LabVIEW runtime engine. To correct this problem, contact the COCKPIT vendor or download the LabVIEW runtime engine from the National Instruments website.”

i tried to instal LabVIEW runtime 2012 and it didn't work also

Could you please advise on how I can resolve this issue? 

Any guidance or suggestions would be greatly appreciated.

Thank you for your assistance.

Best regards, ABDENACER

0 Kudos
Message 1 of 6
(383 Views)

With LabVIEW you can open old sources and recompile for latest Run-Time, but you can't "open application" as executable, of course.

It looks like that you have LV2012 32-bit app, but installed LV2012 64 bit Run-Time or visa versa.

Check exact version which is required for your application and install exactly this version (bitness is important too), then it should work (if there are no other dependencies).

Message 2 of 6
(376 Views)

To run an executable from LV2012 you need the LV2012 runtime engine, just like you need DirectX 9 for DX9-games. You also need a fitting DAQ version.

G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
Certified-LabVIEW-Developer
Message 3 of 6
(301 Views)
 
0 Kudos
Message 4 of 6
(242 Views)
Solution
Accepted by topic author ABDENACER

@ABDENACER wrote:
 

If "The injector test bench requires version 8.5.1", then obviously, try to download and install LabVIEW Run-Time 8.5.1.

 

Message 5 of 6
(236 Views)

... and the latest DAQ that goes with LV8.5 is DAQ 7.5

Archived: Traditional NI-DAQ (Legacy) and LabVIEW Compatibility - NI

G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
Certified-LabVIEW-Developer
0 Kudos
Message 6 of 6
(184 Views)