LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Installing error

Solved!
Go to solution

I clicked continue and it seemed to install one or two additional things. Here are the final screens:

 

 

sc1.png

 

sc2.png

 

0 Kudos
Message 11 of 18
(889 Views)
Solution
Accepted by topic author wmeaney

It's a little difficult to read the tiny fuzzy print in your full-screen images, but the last two pictures of the Firewall notice and "One or more errors occurred" are helpful.  First, the Firewall notice is just that, a notice.  It's normal.  The second is more worrisome -- it appears that you ignored my advice and went to the download page for NI Elvis Software for LabVIEW 2018.  No!  Go find the installer for LabVIEW 2018.  Install only LabVIEW 2018.  If it fails to install (i.e. if you get an error saying "Could not install XXX.  Ensure you have sufficient privileges to install Services", then do the following:

  • Don't bother to "Try Again" -- just cancel.
  • What you want to do is to then ignore the error and continue installing the rest of the package.  I don't remember the exact wording, but you sort of answer "No" (don't try again), maybe another "No", but eventually "Yes, install other things".

When you finish, you'll get another "Error in installation" warning like you showed below.  Reboot, then do exactly the same installation, from the same download of LabVIEW 2018, a second time.  What should happen it is will whiz through the stuff already installed, will (probably) install whatever gave it heartburn previously, and then whiz pass the rest of the stuff it already installed, finishing with "Software installed successfully".  Once it does, reboot.  Now you can try to install the Elvis 2018 drivers.

 

Bob Schor

0 Kudos
Message 12 of 18
(878 Views)

The NI Elvis Software is the installer link my professor gave me. I set the installer to only install LabView and unselected everything else

0 Kudos
Message 13 of 18
(870 Views)

@wmeaney wrote:

The NI Elvis Software is the installer link my professor gave me. I set the installer to only install LabView and unselected everything else


And that didn't work, did it?  You can do a Web search and find the link to download the LabVIEW 2019 software (without Elvis).  Please feel free to ignore this advice.

0 Kudos
Message 14 of 18
(834 Views)

I uninstalled labview again and went to download the general labview installer. Since the license key my professor is providing is for 2018 SP1, I think that I need to use the 2018 SP1 installer. (https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019PnjSAE) I went to download 2018 SP1 from https://www.ni.com/en-us/support/downloads/software-products/download.labview.html#306369, but got the following message:

 

Previous versions are available only to customers with an active standard service program (SSP) membership. Purchase or renew SSP to access locked versions.

 

I also found a different download link http://www.ni.com/download/web-based-installer-labview-development-system-2018/7924/en/

It's a software platform bundle, but the page says that it's a LavBIEW 2018SP1 Web-based installer. Is this what you are suggesting?

 

 

 

 

 

0 Kudos
Message 15 of 18
(822 Views)
Solution
Accepted by topic author wmeaney

My apologies -- I said to find the LabVIEW 2019 installer, but I meant LabVIEW 2018.  Try this link.  

 

Bob Schor

Message 16 of 18
(809 Views)

Thanks for your help the past few days. The general installer worked perfectly. I got the other stuff installed correctly in the order you stated. It still seems kinda weird that installing the base program with one installer failed and a different installer worked...maybe the more specific installer has a bug.

0 Kudos
Message 17 of 18
(784 Views)

@wmeaney wrote:

Thanks for your help the past few days. The general installer worked perfectly. I got the other stuff installed correctly in the order you stated. It still seems kinda weird that installing the base program with one installer failed and a different installer worked...maybe the more specific installer has a bug.


I would assume the installer was just for the addon and the message was ill formed, it wouldn't be the first. 🙂

/Y

G# - Award winning reference based OOP for LV, for free! ADDQ VIPM Now on GitHub
"Only dead fish swim downstream" - "My life for Kudos!" - "Dumb people repeat old mistakes - smart ones create new ones."
Certified-LabVIEW-Developer
0 Kudos
Message 18 of 18
(769 Views)