LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to write double numbers with point as decimal character

Solved!
Go to solution

Hi all,

 

It is probably a stupid question but I really cannot find a solution to my problem.

 

Both on the front panel and the block diagram every time I write a decimal number I use the point but LabVIEW writes down a comma for the decimal character.

 

This is really annoying and becomes extremely dangerous when writing commands for an instrument since the point should be the decimal character and the comma is the separator between different arguments for a given command.

 

How can I solve my problem?

 

Many thanks in advance!

 

0 Kudos
Message 1 of 3
(722 Views)
Solution
Accepted by topic author mol90

See Tools->Options...->  section Front Panel - General. Uncheck "Use localized decimal point" and restart LabVIEW.

Paolo
-------------------
LV 7.1, 2011, 2017, 2019, 2021
Message 2 of 3
(713 Views)

Check out the section on "Localization Codes" here: https://zone.ni.com/reference/en-XX/help/371361R-01/lvconcepts/format_specifier_syntax/

 

You probably want your format to look like this: "%.;%f"

0 Kudos
Message 3 of 3
(711 Views)