LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to have Labview project file release the memory of an ImagingSource camera

Hi friends,

 

Currently, I am working on implementing an image registration function into our system using an imagingsource camera and its labview extension. Specifically, what the function does is take photos of a sample and compare them to a reference image. Then, based on the pixel differences, a motorized stage can move the sample around to match the reference image. The way I construct a program to do so is to firstly connect to an imagingsource camera and then use it to take and save a picture for either a reference or a later on image for comparision. After having these images, the program runs an algorithm to do image registration and move a stage accordingly. So, the program here can display live images and do image registration, while in our system, we also run other measurements which also need the image registration function and here comes the problem. 

 

In our system, there is a main/master program which can call out other side programs, and the above-mentioned imaging program is one of those side programs. At the beginning, the program is working well if I only opened the main program and used it to call out the imaging program. The imaging program can display live images and do whatever it is capable of. However, when I closed the imaging program and then ran several measurements which used the image registration function, there was always an access denied of the camera when I re-opened the imaging program and connected to the imaging source camera. I tired to use one of the imagingsource labview extension, named clean imaging control or something, to clean the camera memory holding by a given measurement but still no joy. To remedy this access denial, I have to fully close the entire labview not just the main and side programs but the entire labview itself. I've contacted the imagingsource team for this, but I did not get any updates from them thus far. I am hoping I can have some pointers here. I've attached the error message I've been getting and the imaging program for future reference. Any pointers will be greatly appreciated, and of course, I will be happy to provide the related info if needed.  

 

I am using Labview 2020 and the imaging source labview extension (https://www.theimagingsource.com/en-us/documentation/icextlvi/).

image.png

0 Kudos
Message 1 of 2
(329 Views)

image.png

somehow I couldn't upload the image. Here is the error message screen shot. 

0 Kudos
Message 2 of 2
(328 Views)