LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Help with BiSS protocole

Hello everyone,

 

I want to intergrate on labview an absolute encoder from Renishaw.

Here it is:

http://www.renishaw.com/en/resolute-take-the-product-tour--10940

 

It uses Biss protocole, 26 bits.

The company provide a small soft, to read data from the device, and it look like this:

E201.jpg

 

Usually it works and display the position but right now for some reasons it doesn't find the device, even though it is plug.

 

Anyway, would you have any tips on how I can get the data from this device/protocole in Labview?

0 Kudos
Message 1 of 7
(3,724 Views)

Here is how the soft works when working

E201-2.jpg

0 Kudos
Message 2 of 7
(3,694 Views)

For interfacing a Resolute absolute encoder with LabVIEW, you'll need to be able to create an SSI/BiSS interface.

 

Typically this is done with an FPGA device, for which you have two options:

 

- design your own electronics interface and write your own FPGA code, probably integrating IP from icHaus (link)

- use a C-series module from SEA GmbH in a CompactRIO chassis (SEA 9521)

 

Strictly speaking that diagnostic system is designed for use with RLS absolute encoders and may not always work with Resolute readheads. The 26-bit should be able to, but it doesn't look like it's been set up properly. For instance, the BiSS protocol that Resolute uses contains CRC data, and it's set to zero in the screenshot. I would recommend getting in touch with your local Renishaw sales representative and asking them for support.

 

If you can get the E201 working, you can send and receive serial commands to and from the device using VISA - have a read of the E201 datasheet.

---
CLA
Message 3 of 7
(3,679 Views)

Hey thanks for your answer 🙂

 

That's actually what I am trying to do. 

The E201 usb encoder interface is working with the provided soft, and now I am trying to communicate with it in labview with VISA

0 Kudos
Message 4 of 7
(3,669 Views)

Oh I succeeded! Letme make a nice vi and i'll share it here 😉

0 Kudos
Message 5 of 7
(3,663 Views)

Quick question:

Under labview, the decimal value the encoder return for the position doesn't correspond to the position on the rule provided with it in mm.

The software, does. At the beggining of the 10 cm rule it shows 0, then goes up, all in mm.

But the value returned under labview goes from about 33816691 to 33820441.

 

I assume there is some kind of table or algorithm within the soft to convert these values in mm.

Anyone would know how to find it and implement it under my labview VI?

 

 

0 Kudos
Message 6 of 7
(3,624 Views)

Have you been able to develop the labview VI for SSI / Biss ?  If you have, could you post it?  What hardware did you use?

 

Thank you very much.

0 Kudos
Message 7 of 7
(2,663 Views)