LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Help establishing internet connection on cRIO 9045

Solved!
Go to solution

I have an application running on a cRIO 9045 that controls a long term test. I'd like to give this application the ability to send out email notifications, but am unable to get an internet connection on the cRIO. The cRIO is connected to the company's internal network by ethernet, and the IT department has given me an IP address, subnet mask, and gateway that they've assigned to it. After entering that information in MAX, I can connect to the cRIO from anywhere on the company network, but I still do not have internet access on the cRIO.

 

I've tried checking for internet access using both these methods, and both come back negative.

https://learn-cf.ni.com/teach/riodevguide/code/rt_email.html
https://learn-cf.ni.com/teach/riodevguide/code/rt_check-internet-access-http.html

 

Are there any further setup that needs to be done on my end, or is it possible that there are other changed that need to be made by the company's IT department?

0 Kudos
Message 1 of 7
(1,184 Views)

You need to talk to your IT department.

 

You haven't given any information as to how you are sending the e-mail, is it g-mail?  Company's mail server? ....?

 

IT departments usually have some strict rules and firewalls, particularly for access to a mail server.  Perhaps you need to be logged into the network as a user, but a cRIO really doesn't have the concept of a user.

0 Kudos
Message 2 of 7
(1,107 Views)

I'm trying to send email through a personal gmail account that I set up just for this purpose. On the development computer, I can get a simple VI to send emails from inside the company network, but not on the cRIO. If there aren't any additional steps needed to get internet access on a cRIO, then I'll talk to IT and see what they can do for me.

0 Kudos
Message 3 of 7
(1,103 Views)

Forget e-mail for the moment and try something else.

 

See if you can get an HTML request to go out and get a response.  That should prove you have internet access.

 

As for g-mail, g-mail itself as some security settings.  One account setting it so allow for less secure apps to access it.  I had to turn that on for some of our applications.  The other thing is that even with that, when I get an application on a new PC to run for the first time, I find that g-mail will block the attempt to send an e-mail.  If I am on that PC and log into G-mail, then go through the authorization process to allow a new device to access the g-mail account, then I don't have problems with that new device sending e-mails.  If I don't do that, the e-mail doesn't seem to be sent and I'll see an e-mail message in the G-mail account saying there was a suspicious attempt to access it.

 

You might be dealing with a situation like that.  And being a cRIO means it is more difficult to work around it since you don't have a user interface to do things like log into g-mail from a browser on a cRIO.

0 Kudos
Message 4 of 7
(1,094 Views)
Solution
Accepted by topic author Alex_White

Problem solved.

 

I had taken for granted that windows automatically picks a DNS server if you leave it blank. I had left the DNS server in the cRIO as 0.0.0.0. Changed it to Google's DNS 8.8.8.8 and everything works now.

0 Kudos
Message 5 of 7
(1,052 Views)

Hi, we are trying to do the same thing and think we are running into the same problem. How do you change the DNS Server to 8.8.8.8?

0 Kudos
Message 6 of 7
(330 Views)

You can find instructions for setting up a static IP address and manually assigning a DNS server here.

 

Configure CompactRIO With a Static IP Address - National Instruments (ni.com)

0 Kudos
Message 7 of 7
(318 Views)