LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Frontpanel screenshot

Hi,

 

what´s wrong with this? I don´t get any error. The clipboard is empty.I want to make a screenshot of frontpanel.

The same version with invoke node "print" is working fine

 

Thank you

0 Kudos
Message 1 of 6
(462 Views)

Hallo Hulk,

 


@Hulk1978 wrote:

what´s wrong with this? I don´t get any error. The clipboard is empty.


There is no clipboard involved in your snippet, so why do you expect any data in the clipboard?

This snippet just gets the frontpanel image and provides it in the "Bilddaten" indicator…

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO
0 Kudos
Message 2 of 6
(460 Views)

Because of same reason why the printer invoke node is working.

0 Kudos
Message 3 of 6
(453 Views)

Hallo Hulk,

 


@Hulk1978 wrote:

Because of same reason why the printer invoke node is working.


Which "same reason"?

When you print something using an invoke node then you send some data to a printer. I expect this works as expected.

 

When you request the frontpanel image of your VI then you get the frontpanel image of your VI. Why do you expect it to be copied to the clipboard when you don't program it that way?

You need one more invoke node to write data to the clipboard…

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO
0 Kudos
Message 4 of 6
(450 Views)

does the second invoke need a reference too?

The clipboard is still empty. But saving picture is working.

 

thanks

0 Kudos
Message 5 of 6
(434 Views)

i checked with read clipboard invoke. It´s not empty. But copy picture is not possible

0 Kudos
Message 6 of 6
(404 Views)