LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Failure to initialize lvanlys DLL

Highlighted

On a new HP computer running Windows 10, I've installed LabVIEW 2017, and am encountering the following error.

 

When I try to load any code that contains subVIs which initialize the lvanlys library, or I try to place such a subVI (for example, the "Mean" subVI) into a code, I get the following error message:

Error loading "C:\Program Files\National Instruments\LabVIEW 2017\resource\lvanlys.dll" A dynamic link library (DLL) initialization routine failed.

 

For the "Mean" example (code example attached), this error occurs twice, and then the subVI will place in the code. However, the code will still return an error (see attached PNG file).

 

Digging into the subVI, I see that it's trying to call the path:

e:\builds\penguin\labview\branches\2017\dev\dist64\resource\lvanlys.*

I assume this is a part of the build environment, but don't really understand it. 

 

Looking at other forum posts, I've checked:

  • that the lvanlys dll is present where it should be
  • that I have the needed runtime engines installed and running
  • that the MKL (math kernel library) is where it should be
  • that everything is up-to-date with LabView

I've tried uninstalling/installing three different ways (through my campus software library link, through the National Instruments website, and through the National Instruments website using the online installer), including deleting all National Instruments folders when I uninstall, and get the same error each time, and my department IT has been unable to solve it. 

 

Thank you for any help!

Download All
0 Kudos
Message 1 of 15
(1,639 Views)
Highlighted
  • Is this 32bit or 64bit LabVIEW? (looks like 64bit. Why?)
  • Are you installing into the default paths or are you customizing anything during installation?
  • Are you running any unusual security or AV software?
  • I don't understand why you would need runtime engines installed and running. Please explain why you did that.
  • ...

LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 2 of 15
(1,634 Views)
Highlighted
  • This is 64bit. The reason I installed 64bit on this computer (which is an office computer) is because 64bit is what is installed on the lab computers I'll be running the code on.
    • The lab computer I primarily use is still running on LabVIEW 2016. I've paused from updating the lab computers I use to the newest version since I've encountered this issue, though my research group has a couple of other computers running LabVIEW 2017 just fine, as far as I'm aware.
  • The install was default.
  • I'm not running any unusual security software that I'm aware of. I suppose there could be something strange with the network security, but all of our other computers are also hooked up to the network, and aren't giving this issue. 
0 Kudos
Message 3 of 15
(1,627 Views)
Highlighted

I still don't understand your comment about run time engines.


LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 4 of 15
(1,604 Views)
Highlighted

I'm having trouble finding the precise forum posts that I saw before, but from at least one where a similar dll intialization issue was occurring, one of the comments was to check the installed run-time engines using NI MAX:

 

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P8WzSAK

 

It could very well be that run-time engines aren't actually relevant to this issue. I'm not very knowledgable about many things under the LabVIEW surface, so I appreciate any insights. 

0 Kudos
Message 5 of 15
(1,571 Views)
Highlighted

After you get the dialogues pop up, it sounds like the code runs.  Is that correct?  Or, am I misunderstanding that entirely?

 

If it does, will saving the VI bring it up a second time without error?

0 Kudos
Message 6 of 15
(1,557 Views)
Highlighted

No, the code won't run.

 

The VI will visually place onto the block diagram once I get through however many error pop-ups are generated, and similarly, the code will load after these errors. For example, for the "mean" VI, the error is returned once when the code tries to load, LabVIEW then searches for the resource again, and returns the error a second time. More complicated mathematical subVIs return the error more times, probably because they call the lvanlys dll more than once.

 

Saving the VI and reloading it results in the same errors. Once loaded, the code is still broken, and returns the attached error list if I try to run the code. 

0 Kudos
Message 7 of 15
(1,551 Views)
Highlighted

I have the same problem. Did you ever resolve it?

0 Kudos
Message 8 of 15
(360 Views)
Highlighted

Does your computer contain an AMD Ryzen CPU?

Rolf Kalbermatter
Averna BV
0 Kudos
Message 9 of 15
(356 Views)
Highlighted

My system runs AMD Ryzen 7 3700X 8-Core Processor 3.59 GHz

0 Kudos
Message 10 of 15
(343 Views)