LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Fail in hiding .NET container

Hi,

 

I am tring to hide the .NET container, I left click the container and choose advanced->hide control, it disappear. However, when I save the file or run the file, it appears again. Why? How can I totally hide that? Thanks!

 

Xuanyi

11.jpg

0 Kudos
Message 1 of 2
(106 Views)

Do you just never ever want to see it, or do you want to sometimes hide it and sometimes show it?

 

If you want to sometimes hide and sometimes show, try putting it on an invisible tab control:

1. Put down a tab control, move the .NET control into it

2. Hide the label and tabs with the "Visible" right-click option

3. Switch to the color control tool 

4. Right-click on the tab control, then choose the "T" in the upper right of the color selector to select "Transparent"

 

You can then use property nodes of the Tab to change pages to hide/show it.

 

If you never want to see it at all, you can change Thorlabs to just use a constructor node to create its motion control references, instead of using the .NET control on the front panel.  All of their example code uses the front panel control, but it's not actually necessary.

0 Kudos
Message 2 of 2
(101 Views)