LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 8 in Save Configuration when using executable

Solved!
Go to solution

I have a vi that accesses and writes to a configuration file in the default data directory. The compiled version works. But the executable gives the following error:

---------------------

Error 8 occurred at Set File Size in NI_LVConfig.lvlib:Save Config File.vi->NI_LVConfig.lvlib:Close Config Data.vi-> (name of my vi). 

Possible reason(s) ...File permission error. You do not have the correct permissions for the file======DMA hardware error detected.

----------------------

I have disabled the firewall and the same error appears.

 

Any ideas on what the problem is?

 

0 Kudos
Message 1 of 6
(1,207 Views)

@tjw2 wrote:

I have a vi that accesses and writes to a configuration file in the default data directory. The compiled version works. But the executable gives the following error:

---------------------

Error 8 occurred at Set File Size in NI_LVConfig.lvlib:Save Config File.vi->NI_LVConfig.lvlib:Close Config Data.vi-> (name of my vi). 

Possible reason(s) ...File permission error. You do not have the correct permissions for the file======DMA hardware error detected.

----------------------

I have disabled the firewall and the same error appears.

 

Any ideas on what the problem is?

 


Yes.  You don't have the correct permissions for the file.  Maybe LabVIEW has permission to use that folder, but a "normal user" does not?

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 2 of 6
(1,191 Views)
Solution
Accepted by topic author tjw2

Thanks for the reply but I had full permissions. It turned out that even when I turned off the firewall in Norton 360, it still prevented access. I had to 1) make sure that Norton was set to report and files it blocked, 2) click the link in the report to get details, 3) click another link to get information about the file, and 4) click the "trust this file". Now it's working.

Message 3 of 6
(1,172 Views)

I found the problem. It was Norton 360 (even though I had turned off the firewall). See my reply to Bill for a further description.

0 Kudos
Message 4 of 6
(1,171 Views)

@tjw2 wrote:

Thanks for the reply but I had full permissions. It turned out that even when I turned off the firewall in Norton 360, it still prevented access. I had to 1) make sure that Norton was set to report and files it blocked, 2) click the link in the report to get details, 3) click another link to get information about the file, and 4) click the "trust this file". Now it's working.


Wow!  Make sure to mark your post as the solution!  🙂

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 5 of 6
(1,164 Views)