LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Creating System Dialog Buttons with Custom Icons and Mouse Hover Effects

[cross-posted on lava]

If you've ever seen the cool system buttons with glyphs and mouse-hover effects in VI Package Manager and wondered "how'd they do that?", then here's a tutorial video you should check out:

Creating System Dialog Buttons with Custom Icons and Mouse Hover Effects

Thanks,

-Jim


Message Edited by Jim Kring on 07-23-2007 07:54 AM

Message 1 of 9
(4,734 Views)
Hi Jim, I just wanted to ask you if it were possible to post the control created in LV7 so I could finish the tutorial in 8.5 and reach the hover effect as described. I don't have access to LV7. Thanks a lot
LV 2011, Win7
0 Kudos
Message 2 of 9
(4,578 Views)
You can't create this only in LV 8>, but you can take the template from website and use it for.
0 Kudos
Message 3 of 9
(4,570 Views)
I know that I can't make the whole work in LV8.x that's why I am asking the control saved in LV7 which is the only thing that you need from previous version (if I understood the tutorial right). You said something about a template but I didn't find any. Could you point me at it, please? Thanks
LV 2011, Win7
0 Kudos
Message 4 of 9
(4,564 Views)
Yes, here you have one control with 4 states (you will not see the Mouse Hover State in custom mode, but if you run your VI with this control you see it), so you have to replace the picture of each state in customize mode with your one.


Message Edited by Eugen Graf on 01-10-2008 08:40 AM
Message 5 of 9
(4,560 Views)
thanks a lot eugen!
LV 2011, Win7
0 Kudos
Message 6 of 9
(4,548 Views)
Hi all, it's me again. I tried to customize the control. I moved the picture one pixel down and right to create the "pushed effect" as described in the tutorial. Afterwards the button started to act in a weird way and I can't figure out why. When i press it the picture itself moves somewhere else. What does it cause? See attachment and run and press the button. Thanks a lot

Message Edited by ceties on 01-16-2008 09:01 AM
LV 2011, Win7
0 Kudos
Message 7 of 9
(4,493 Views)
Glad to see you found the solution ceties.  For anyone else who may be wondering, you need to deselect the "independent" sizes option after shifting the icon. 
Jennifer R.
National Instruments
Applications Engineer
Message 8 of 9
(4,399 Views)
I forgot to post it here. My fault. Thanks Jennifer!
LV 2011, Win7
0 Kudos
Message 9 of 9
(4,396 Views)